Welcome to LEADTOOLS Product Help

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Welcome to LEADTOOLS Products

LEADTOOLS provides the best in imaging toolkits to developers who are working with the latest Microsoft technologies targeting 32 and 64-bit platforms (including Windows 2000, XP, Server and Vista). It includes both Win32 and x64 libraries for C DLL, C++ class libraries, .NET, WCF, Windows Workflow, WPF, AJAX, and Silverlight. ActiveX and COM Interop interfaces are provided as 32 bit.

LEADTOOLS is ideal for developers involved in still frame, multimedia, document, medical, and vector imaging projects, including Internet/Intranet applications. Independent of the specific application requirement – such as scanning, file format support/conversion, compression, image processing, annotation, database support, and multimedia – LEADTOOLS provides the most comprehensive, robust, flexible, and powerful imaging solution available.

This latest version of the LEADTOOLS Imaging Toolkits introduces many new features and is considered one of the fastest and most robust versions of LEADTOOLS ever. The Medical Imaging toolkit offers an updated Medical Viewer Control, 3D support, and several new DICOM PACS Framework add-ins including DICOM worklist, router, high level storage, query, and retrieve.

The Document Imaging toolkit offers an enhanced Asian OCR engine, an all new Arabic OCR engine, XLS OCR output, advanced table detection, and various optimizations in the LEADTOOLS Advantage engine.

The Multimedia toolkit offers an all new .NET library designed specifically for .NET, 64bit binaries, and support for HD Digital TV Tuners.

A full featured Silverlight toolkit is also available in the latest version. Some of these features include DICOM Dataset support, annotation support, an updated viewer, native support for loading over 100 file formats, over 130 image processing functions and pixel shaders, and more.

Other features include enhanced PDF support, the ability to load Powerpoint, WORD, and XLS files as raster, and Analyze Medical format support. ActiveX controls allow you to rapidly use your existing .NET code and incorporate image compression, file format support, and image processing functionality into VB.6 and VC++ applications.

This help file provides product information and pricing for:

  • LEADTOOLS software developer toolkits (SDKs)

  • LEADTOOLS software developer toolkit add-ons, modules, and plug-ins.

  • LEADTOOLS End-User Imaging Utilities

  • LEADTOOLS Codecs and Filters

Supported Environments:

LEADTOOLS comes in Win32 and x64 editions. The environments supported depend upon the specific product, platform and function. For more information, refer to Supported Platforms / Operating Systems.

http://www.leadtools.com/SDK/Multimedia/pcmpchtMM.htm

See Also:

LEADTOOLS Support Forums

Contact Us:

LEAD Technologies, Inc.
Suite 200
1927 South Tryon Street
Charlotte, NC 28203

Email:

Website:

Phone:

FAX:

sales@leadtools.com

www.leadtools.com

(704) 332-5532

(704) 372-8161

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing

© Copyright LEAD Technologies, Inc. 1991-2010. ALL RIGHTS RESERVED


Supported Platforms / Operating Systems

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Supported Platforms / Operating Systems

Imaging, Document Imaging and Medical Imaging Toolkits

Win32 (x86) platforms

Windows 2000, Windows XP, Windows Server 2003, Windows Server 2008, Windows Vista, Windows 7

Win64 (x64) platforms

Windows XP 64-Bit Edition, Windows Server 2003 64-Bit Edition, Windows Server 2008 64-Bit Edition, Windows Vista 64-Bit Edition, Windows 7 64-Bit Edition

Windows Mobile 5*

Windows Mobile 6*

Multimedia Toolkit – COM

Win32 (x86) platforms – All objects and functions.

Windows 2000, Windows XP, Windows Server 2003, Windows Server 2008, Windows Vista, Windows 7

Win64 (x64) platforms – All objects and functions.

Windows XP 64-Bit Edition, Windows Server 2003 64-Bit Edition, Windows Server 2008 64-Bit Edition, Windows Vista 64-Bit Edition, Windows 7 64-Bit Edition

Windows Mobile 6* – ltmmPlayCtrl object and functions.

Multimedia Toolkit – API

Win32 (x86) platforms – All interfaces and functions.

Windows 2000, Windows XP, Windows Server 2003, Windows Server 2008, Windows Vista, Windows 7

Win64 (x64) platforms – All interfaces and functions.

Windows XP 64-Bit Edition, Windows Server 2003 64-Bit Edition, Windows Server 2008 64-Bit Edition, Windows Vista 64-Bit Edition, Windows 7 64-Bit Edition

Windows Mobile 6* – ltmmPlay interface and functions.

Multimedia Filters

Win32 (x86) platforms –All filters

Windows 2000, Windows XP, Windows Server 2003, Windows Server 2008, Windows Vista, Windows 7

Win64 (x64) platforms – All filters

Windows XP 64-Bit Edition, Windows Server 2003 64-Bit Edition, Windows Server 2008 64-Bit Edition, Windows Vista 64-Bit Edition, Windows 7 64-Bit Edition

Windows Mobile 6*

    • LEAD H263 Decoder (2.0)

    • LEAD H264 Decoder (3.0)

    • LEAD MPEG-2 Decoder (2.0)

    • LEAD MPEG-4 Decoder

    • LEAD MCMP/MJPEG Decoder (2.0)

    • LEAD MPEG Audio Decoder

    • LEAD MPEG2 Transport Demultiplexer

    • LEAD MPEG2 Program Demultiplexer

    • LEAD ISO Demultiplexer

    • LEAD Video Text Overlay Filter (2.0)

* Can be found on many modern mobile devices, including:

  • Windows Mobile Professional, which runs on 'Windows Phones' (smartphones) having touchscreens

  • Windows Mobile Standard, which runs on 'Windows Phones' having regular screens

  • Windows Mobile Classic, which runs on 'Windows Mobile Classic devices' (Pocket PCs).

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS Products

LEADTOOLS Software Developer toolkits (SDKs)

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Mobile Imaging

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS PACS Imaging

LEADTOOLS Multimedia

Modules, Plug-ins, and Add-ons

LEADTOOLS Virtual Printer Module

LEADTOOLS Medical Multimedia Module

LEADTOOLS Barcode Modules

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Module

LEADTOOLS Raster PDF Plug-ins

LEADTOOLS DVD Module

LEADTOOLS DVR Module

LEADTOOLS Video Streaming Module

LEAD MPEG-2 Transport Module

End User Imaging Products

LEADTOOLS ePrint Professional

LEADTOOLS ePrint Terminal Server Edition

LEADTOOLS ePrint API

LEADViEW

Additional Codecs/Filters

LEAD H.263 Video Codec

LEAD H.264 Video Codec

LEAD MJPEG2000 Codec

LEAD MPEG-2 Video Codec

LEAD MPEG-4 Video Codec

LEAD Video Codec (MCMW)

LEAD Video Codec (MJPEG / MCMP)

LEAD AAC Audio Codec

LEAD Vorbis Audio Codec

LEAD AMR Audio Codec

LEAD AC3 Audio Encoder


LEADTOOLS Imaging

Available in the LEADTOOLS Imaging toolkit.

LEADTOOLS Imaging ($495)

Price includes:

Development seat, application license, and unlimited deployment license for internal and/or commercial deployments.

Platform Components:

ActiveX controls, WPF/XAML controls, and COM objects.

Product Description:

LEADTOOLS Imaging provides support for adding to any application the ability to display, load, save, convert or process images. This toolkit gives developers the ability to interact creatively with front-end designers, create extremely small footprint applications, obtain low-level access to pixel data, create custom image processing filters, exert full control over load/process/save functions, share images (without copying) via DIBs/DDBs, and exert full control over all display options.

Key Features:

  • WPF controls enable you to build applications that blend the user interface, documents, images, and other content for delivery on the desktop or across-the-web.

  • ActiveX controls allow you to display and manipulate image lists and incorporate image compression, file format support, and image processing functionality into your applications.

  • COM objects provide TWAIN device support with Windows Common Dialog boxes that incorporate LEADTOOLS Imaging functionality.

This product includes:

LEADTOOLS ActiveX (OCX)

LEADTOOLS Win32 COM

LEADTOOLS WPF Standard .NET


LEADTOOLS Imaging Pro

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS Imaging Pro ($995)

Price includes:

Development seat, application license, unlimited internal deployment and up to 1000 commercial desk top deployments/5 commercial production server deployments per year. Annual and multi-year unlimited deployment licenses are available for commercial deployment. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, and AJAX web controls

Product Description:

LEADTOOLS Imaging Pro provides support for adding to any application the ability to display, load, save, convert or process images. This toolkit gives developers the ability to directly call exported DLL functions, create extremely small footprint applications, obtain low-level access to pixel data, create custom image processing filters, exert full control over load/process/save with callbacks, share images (without copying) via DIBs/DDBs, and exert full control over all display options. The provided AJAX web controls support tiling, so only the necessary portions of an image are downloaded to the browser. Non "browser friendly" formats are decompressed on the server and send back to the client in a "browser friendly" format allowing developers to create web applications that support 150+ formats.

The LEADTOOLS Imaging Engine provides full application development support for:

  • Color Conversion, Display, and Compression for over 150 Image Formats, including: JPEG, J2K, TIFF, CCITT G4, CMW, NITF, LEAD's proprietary CMP, extended FlashPix, and ABC (read-only);

  • Image Processing, including Transforms, Filters, Drawing, and Region of Interest;

  • AJAX Enabled WebForm Controls

  • More than 2000 Special Effects;

  • Printing;

  • Internet/intranet imaging;

  • Database imaging;

  • Imaging Common Dialogs;

  • Screen Capture; and

  • Windows Presentation Foundation (WPF) Pro

This product includes:

Color Conversion

Image Compression

Image Processing

Image Processing: Region of Interest

Image Display

Imaging Common Dialogs

Special Effects: Display and Drawing

DigitalPaint

Scanning / Screen Capturing

Fast TWAIN Support

AJAX Enabled WebForm Controls

Windows Image Acquisition (WIA)

Printing

Peer-to-Peer Networking

Database Imaging

LEADTOOLS WPF Standard .NET

Windows Presentation Foundation (WPF) Pro

Load/Save Support for 150+ File Formats

National Imagery Transmission Format (NITF) Support

Advanced Bitonal Compression (ABC) Support (read)

FlashPix Support

This product is included with:

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Other LEADTOOLS products that can be added to this product:

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules


LEADTOOLS Mobile Imaging

LEADTOOLS Mobile Imaging ($595)

Price includes:

Development seat, application license, unlimited internal deployment and up to 1000 commercial desk top deployments/5 commercial production server deployments per year. Annual and multi-year unlimited deployment licenses are available for commercial deployment. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Supported Platforms:

Imaging Library for Microsoft .NET Compact Framework; C DLL

Product Description :

LEADTOOLS Mobile Imaging is a programming SDK for the Microsoft .NET Compact Framework. Developers now have access to LEADTOOLS imaging functionality for applications designed to run on devices such as personal digital assistants (PDAs) and mobile phones.

Many features available in LEADTOOLS Imaging Pro for .NET are also available in the LEADTOOLS Mobile Imaging SDK. Some of these are:

  • File Format Support - Read, write and convert image files of the most popular standard image formats, including JPEG, JPEG2000, LEAD CMP, LEAD CMW, TIFF(uncompressed, RLE compressed, LZW compressed, FAX (CCITT/G3/G4) compressed), GIF, PNG, BMP and EXIF. Additionally, 12-16 bit grayscale load/save is supported.

  • Display - Complete control of how the image is displayed including zoom, scroll, dither, resample and bicubic resized display and ScaleToGray and FavorBlack resized display for bitonal images.

  • Image Processing - Use digital filters and transforms to process images. Resize, rotate, flip, combine, crop, fill, grayscale and color resolution.

LEADTOOLS Mobile Imaging ships with binaries that support the following platforms and processors:

  • PocketPC 2003

    • ARMV4

    • Emulator

  • SmartPhone 2003

    • ARMV4

    • Emulator

  • StandardSDK 4.20

    • ARMV4

    • ARMV4I

    • Emulator

    • MIPSII_FP

    • MIPSII

    • MIPSIV_FP

    • MIPSIV

    • SH3

    • SH4

    • X86

  • StandardSDK 5.00 (Windows Mobile 5 and later)

    • ARMV4I

    • Emulator

    • MIPSII_FP

    • MIPSII

    • MIPSIV_FP

    • MIPSIV

    • SH4

    • X86

This product includes:

File Format Support

Image Display

Image Processing

Other LEADTOOLS products that can be added to this product:

LEADTOOLS Barcode Modules


LEADTOOLS Vector Imaging Pro

Available in LEADTOOLS Vector Imaging toolkits.

LEADTOOLS Vector Imaging Pro ($1995)

Price includes:

Development seat, application license, unlimited internal deployment and up to 1000 commercial desk top deployments/5 commercial production server deployments per year. Annual and multi-year unlimited deployment licenses are available for commercial deployment. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL and C++ class library

Product Description:

The LEADTOOLS Vector Imaging Pro toolkit includes everything you need to create powerful 2-D and 3-D viewers, editors, and converters that support both vector and raster image formats. By creating these types of applications, you eliminate the need to install or license the more expensive original application that created the vector files, and you only have to include the functionality for your specific needs.

LEADTOOLS Vector Imaging Pro provides support for 2D and 3D Vector formats, including imaging, loading, viewing, modifying and saving vector files to memory or disk. Vector files can be loaded from one format and saved as another, without the need for the original application that created the file. Vector image formats can be loaded, saved, converted and exported to any of 120+ raster formats.

Support for primitive objects includes Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping.

Vector drawings can be edited in any way desired including adding, modifying, deleting and copying objects into the clipboard or between different vector drawings. Vector drawings can be scaled to any resolution desired without distorting the original image, ensuring that fine details of the drawing will not be lost during printing.

This product includes:

LEADTOOLS Imaging Pro

Vector Imaging

Other LEADTOOLS products that can be added to this product:

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules


LEADTOOLS Document Imaging

Available in LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Document Imaging ($2495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Desktop alone, concurrent and server licenses available. Annual and multi-year unlimited licenses are also available. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, WCF Services, Windows Workflow, Silverlight, and AJAX

Product Description:

The LEADTOOLS Document Imaging toolkit includes all of the display functionality in LEADTOOLS Imaging Pro, and adds extra features to meet the specific demands of the document imaging market. key features include:

  • Powerful annotation capabilities, including Silverlight and WPF annotations;

  • WCF Services that support file conversion, image processing, document cleanup, barcode, and OCR;

  • Windows Workflow components that support file conversion, image processing, document cleanup, barcode, OCR, and high speed scanning;

  • Silverlight image viewer control for panning, zooming, scrolling, and more;

  • Specialized image processing filters, including despeckle, deskew, favor black, and scale-to-gray;

  • Document clean-up such as border remove, hold punch remove, dot remove and more.

  • CD/DVD Burning;

  • Ultra-fast image rotation.

Specialized functions can be used to process scanned images and vastly improve image quality. When used in conjunction with OCR pre-processing, these greatly improve recognition accuracy and performance. LEADTOOLS Doc-Clean features remove noise, borders, lines and hole punches, smooth text, and invert white on black text. Other functions straighten skewed bank checks and digitized images (deskew), fatten thinning lines and text (dilatation) and thin text that appears too thick (erosion).

LEADTOOLS WCF services are included for image conversion, image processing, document image cleanup, OCR, and barcode detection. These services may be accessed via several protocols including HTTP, TCP, IPC and MSMQ, and hosted in a variety of environments including IIS, Windows Activation Services, and within standard .NET applications (Winforms, WPF, Workflow, ASP.NET).

LEADTOOLS Windows Workflow components are also included adding support for image conversion, image processing, document image cleanup, OCR, barcode detection, and high speed TWAIN scanning. Workflow components can be used within Windows Workflow applications, as well as other environments that support Workflow components such as Sharepoint.

The LEADTOOLS Silverlight image viewer control features several user interactive modes including pan, scale, center at, zoom to and a customizable mag glass. Additionally, images can be zoomed and displayed using several different size modes such as normal, fit, fit width and stretch. Native load and save support for over 100 image formats and over 130 image processing functions/pixel shaders is also included. When used in conjunction with our WCF Services, the control can be extended to support 150+ formats.

In addition, the LEADTOOLS MRC (Mixed Raster Content) file format results in both high compression factors and high detail retention. This format enhances LEADTOOLS file input/output functionality by adding support for raster color documents containing mixed image and text components.

LEADTOOLS Document Imaging also fully supports all three types of powerful JBIG and JBIG 2 compression technology, including progressive save. This allows you to store and send multiple representations of images at different resolutions without additional storage overhead.

Even more powerful is LEADTOOLS proprietary Advanced Bitonal Compression (ABC) compression. Superior to JBIG2, LZW, TIFF Group 4, ABIC, and other 1-bit compression, both read and write capability is included with LEADTOOLS Document Imaging.

Additional bitonal (black-and-white) scaling and display options greatly increase the quality and readability of black and white images on the screen. You can use images acquired as document (halftone), grayscale or color in image-intensive applications such as bank check and form processing, stock photo collections, and interactive websites, and archives.

This product includes:

LEADTOOLS Imaging Pro

Additional Document Imaging Features

Document Clean-up

Annotations

Fast TWAIN Scanning

JBIG Support

LEADTOOLS Advanced Bitonal Compression (ABC)

MRC

ABIC

IOCA/MODCA

WCF Services

Windows Workflow Components

CD/DVD Burning

JPIP

LEADTOOLS Silverlight

This product is included with:

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

The following LEADTOOLS products can be added to this product :

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Virtual Printer Module

LEADTOOLS Barcode Modules

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


LEADTOOLS Recognition

Available in LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Recognition ($3995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

.NET classes

Product Description:

LEADTOOLS Recognition SDK is a handpicked collection of other LEADTOOLS SDK's designed to help systems developers build end-to-end document applications for capturing, classification, forms processing, archiving and viewing as part of an enterprise level document automation solution. This powerful set of tools harnesses LEAD's industry LEADing image processing technology to intelligently identify document components and features that can be used to recognize and classify any type of digital form including scanned and faxed images.

The provided Recognition and Processing engines allow developers to fully automate document classification and data extraction for known forms. The Recognition engine creates unique XML data for each known form which is used to identify any form requiring recognition. The Processing engine uses templates, allowing users to define a specific set of fields (along with each field’s type) for each known form. These fields can be defined using the Forms application shipped with the SDK, or developers can create their own template editor using the toolkit. Supported field types include machine and hand written characters, check boxes, filled bubbles, cross marks, barcodes, and more. Support for each type of field requires a corresponding LEADTOOLS OCR, ICR, OMR, or Barcode Module.

In addition to saving the recognized data in various structured output such as delimited text, XML or database fields, the recognized free form document can be converted to searchable PDF to archive for enterprise data mining. For maximum storage efficiency, LEADTOOLS also provides several raster base archival options including PDF MRC, a format designed specifically for images with both color and text areas.

To further enhance the accuracy of the recognition process, this SDK includes LEADTOOLS Document clean-up engine, a set of document image pre-processing tools for deskew and despeckle, as well as line, border and hole-punch removal. For maximum performance, the high level interface also utilizes an intelligent multithreaded algorithm during recognition and processing. With emphasis on thread safety, LEADTOOLS SDK is optimized for enterprise level, service oriented application development. This makes our SDK's an excellent candidate for web hosted and workflow driven application frameworks including WCF and Windows Workflow.

Key Features:

  • Provided as a low and high level .NET interface allowing you to create complete recognition and processing applications with very little code.

  • Full source code for an end-user Forms Recognition and Processing application + hundreds of lines of sample source code.

  • Use in conjunction with LEADTOOLS Document Imaging workflow functions to incorporate scanning, OCR (Advantage engine is included, other engines are available), ICR (hand-written text), OMR (to extract check marks, check boxes, etc), PDF OCR, MICR, redaction, and annotations with recognition and processing.

  • Flexible automatic recognition engine can be customized to use Barcode, OCR, line detection, and special object detection (such as logos, text blocks, and shapes).

  • Loads/saves form identification information as XML for storage in a database.

  • Handles any of 150+ input file formats, including different bits-per-pixel, dpi, scales, skew angles, and noise.

  • Lets you define multi-page forms for recognition and processing.

  • Stores any number of pre-defined forms.

  • Recognizes forms at both form and page level, so you can compare an image to any form page or compare a complete multi-page form to any predefined master form.

  • Recognizes any number of regions or objects on a page.

  • Lets you define, include, and exclude regions of interest in the form.

  • Supports a variety of data fields such as: text, OMR, image, and barcode

    • Text fields support both printed and hand-written text.

    • Supports regular expressions to find / validate text in a specified format.

    • Image fields allow you to extract signatures, personal pictures, logos, and fingerprints.

    • Barcode fields support all barcode Linear(1D) and 2D types, such as PDF417, DataMatrix, QR, EAN, UPC, Databar, and 4-state.

    • Handles different form fields either by name or GUID

  • Enables auto-registration (deskew) and clean-up to improve recognition results.

  • Enables manual feature weighting for improved recognition performance.

  • Generates comprehensive results and confidence level reports to assess performance.

This product includes:

LEADTOOLS Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Advantage OCR Module

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Module

LEADTOOLS Barcode Modules

JPIP (JPEG 2000 Interactive Protocol)

This product is included with:

LEADTOOLS Document Imaging Suite

The following LEADTOOLS products can be added to this product :

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Virtual Printer Module

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules


LEADTOOLS Document Imaging Suite

Available in LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Document Imaging Suite ($4995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Desktop alone, concurrent and server licenses available. Annual and multi-year unlimited licenses are also available. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, WCF Services, Windows Workflow, Silverlight, and AJAX

Product Description:

The LEADTOOLS Document Imaging Suite SDK toolkit includes all of the functionality in LEADTOOLS Recognition, and adds extra features resulting in a single toolkit with everything necessary to build enterprise-level document imaging applications. Provided features include:

  • Complete raster PDF support, both read and write.

  • Output searchable PDF files from OCR recognition.

  • Capture printed output from any application as EMF using LEADTOOLS Virtual Printer Module. Captured EMF files can be converted to any supported document format using LEADTOOLS Document Writers.

  • Convert EMF files to document files including PDF, PDF/A, Word Doc, HTML, RTF and TXT.

  • Forms Recognition and Processing, both high and low level interfaces.

  • Read and Write support for all LEADTOOLS supported barcode types (1D and 2D).

  • Document clean-up functionality.

This product includes:

LEADTOOLS Imaging Pro

LEADTOOLS Recognition

LEADTOOLS Virtual Printer Module

LEADTOOLS Advantage OCR Module

LEADTOOLS OMR Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules

LEADTOOLS PDF OCR Plug-in

JPIP

Additional Document Imaging Features

The following LEADTOOLS products can be added to this product :

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules


LEADTOOLS Medical Imaging

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical Imaging ($4995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Desktop alone, concurrent and server licenses available. Annual and multi-year unlimited licenses are also available. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, WCF Services, Windows Workflow, Silverlight, and AJAX

Product Description:

The LEADTOOLS Medical Imaging toolkit is a comprehensive solution for medical application development. It handles all aspects of end-to-end medical imaging applications development, including capturing, processing, compressing, displaying and printing. Complete support for all Information Object Definitions (IODs) in the DICOM 3 2008 standard will enable your applications to exchange digital information among state-of-the-art, multi-vendor medical imaging equipment and other systems in a picture archiving and communication systems (PACS) environment.

With the LEADTOOLS Medical Imaging toolkit, developers have access to features that have been chosen and optimized to meet the specific demands of the medical imaging market, such as the full DICOM dataset, 1-32 bit grayscale image handling, 12- and 16-bit image processing, overlays, annotation, window leveling, LUT processing, digital signatures, true 16 bit LUT support, support for painting directly to grayscale video cards, DICOMDIR, and a medical image display container with built-in tools for rapid application development.

LEAD's DICOM imaging support is the richest in the industry, supporting 8, 10, 12, 16, 24 and 32 bit images including JPEG (8, 10 , 12, 16-bit Lossless grayscale, 8, 12-bit lossy grayscale, 24-bit lossless and lossy color), JPEG 2000 (8, 10 , 12, 16-bit grayscale and 24-bit color lossless and lossy), Run Length, Uncompressed, Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full), and single and multi-page images.

The LEADTOOLS Silverlight Interface offers a comprehensive set of DICOM features including complete DICOM dataset support (create, load, view, edit, and save), window level, annotations (mark-up), and more.

LEADTOOLS Imaging Pro

LEADTOOLS Document Imaging

Additional Medical Imaging Features

DICOM Basic Features

DICOM Annotation Features

JPIP

The following LEADTOOLS products can be added to this product :

LEADTOOLS Medical Multimedia Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules

LEADTOOLS Virtual Printer Module

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


LEADTOOLS Medical Imaging Suite

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical Imaging Suite ($12995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Desktop alone, concurrent and server licenses available. Annual and multi-year unlimited licenses are also available. For more information, please contact oemsales@leadtools.com or call a LEAD sales representative.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, WCF Services, Windows Workflow, Silverlight, and AJAX

Product Description:

The LEADTOOLS Medical Imaging toolkit is a comprehensive solution for medical application development. It handles all aspects of end-to-end medical imaging applications development, including capturing, processing, compressing, displaying and printing. Complete support for all Information Object Definitions (IODs) in the DICOM 3 2008 standard will enable your applications to exchange digital information among state-of-the-art, multi-vendor medical imaging equipment and other systems in a picture archiving and communication systems (PACS) environment.

With the LEADTOOLS Medical Imaging toolkit, developers have access to features that have been chosen and optimized to meet the specific demands of the medical imaging market, such as the full DICOM dataset, 1-32 bit grayscale image handling, 12- and 16-bit image processing, overlays, annotation, window leveling, LUT processing, digital signatures, true 16 bit LUT support, support for painting directly to grayscale video cards, DICOMDIR, and a medical image display container with built-in tools for rapid application development.

LEAD's DICOM imaging support is the richest in the industry, supporting 8, 10, 12, 16, 24 and 32 bit images including JPEG (8, 10 , 12, 16-bit Lossless grayscale, 8, 12-bit lossy grayscale, 24-bit lossless and lossy color), JPEG 2000 (8, 10 , 12, 16-bit grayscale and 24-bit color lossless and lossy), Run Length, Uncompressed, Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full), and single and multi-page images.

The LEADTOOLS Medical Multimedia Module includes a full Multimedia development toolkit, MPEG-2, Motion JPEG, and JPEG2000 DirectShow filters, and DICOM DirectShow Read and Write filters.

The LEADTOOLS PACS Imaging provides you with everything you need to create both client and server components of a picture archive and retrieval system (PACS) that can retrieve, distribute, and present medical images. The module includes full support for medical data communications, automated processing, and all DICOM client/server classes, command sets, and command elements.

In addition to lower level DICOM Communication features, this product includes LEADTOOLS PACS Framework which makes developing DICOM Service Class Providers and Service Class Users even easier. The framework takes care of the entire behind the scenes work leaving the developer to only develop the service class plug-in implementations. Several sample implementations such as Store, Find, Query/Retrieve, Modality Work List and Storage Commit are included.

The LEADTOOLS CCOW Module encapsulates HL7's vendor independent Context Management Architecture standards. Context Management is a dynamic computer process that uses 'subjects of interest' in one application, to point to data resident in a separate application also containing the same subject.

The LEADTOOLS CCOW SDK contains classes, properties, methods and events that implement:

  • Context participants

  • Context managers

  • Mapping agents

  • Authentication repository

This product includes:

LEADTOOLS Imaging Pro

LEADTOOLS Document Imaging

Additional Medical Imaging Features

DICOM Basic Features

DICOM Annotation Features

LEADTOOLS Medical Multimedia Module

LEADTOOLS PACS Imaging

LEADTOOLS CCOW Module

JPIP

The following LEADTOOLS products can be added to this product :

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules

LEADTOOLS Virtual Printer Module

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


LEADTOOLS PACS Imaging

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS PACS Imaging ($7995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, WPF/XAML controls, .NET classes, WCF Services, Windows Workflow, Silverlight, and AJAX

Product Description:

LEADTOOLS PACS Imaging provides you with everything you need to create both client and server components of a picture archive and retrieval system (PACS) that can retrieve, distribute, and present medical images. The module includes full support for medical data communications, automated processing, and all DICOM client/server classes, command sets, and command elements.

In addition to lower level DICOM Communication features, this product includes LEADTOOLS PACS Framework which makes developing DICOM Service Class Providers and Service Class Users even easier. The framework takes care of the entire behind the scenes work leaving the developer to only develop the service class plug-in implementations. Several sample implementations such as Store, Find, Query/Retrieve, Modality Work List and Storage Commit are included.

LEADTOOLS PACS Imaging also includes LEADTOOLS Web Viewer Framework, a web-based framework based on WCF for distributing medical studies from server to client. The plug-in capable design also allows developers to use the framework for non-DICOM images or binary data transfer, and to extend an implemented web service to include application-specific data transfer and communication capabilities.

Security features fully support secure transport connection profiles with authentication, whether encrypted or unencrypted.

This module supports all storage IOD classes and service classes defined in the DICOM version 3 2008 base standard and all DICOM supplements.

The Medical Workstation Viewer is an end-user-like application with functionality comparable to many DICOM viewers used today in the health care industry. It can be used without modification by medical professionals, by device manufacturers (as a Modality Workstation viewer), research facilities, or anyone that has a need for viewing DICOM images. The source code is provided for easy customization and branding. The workstation is built on LEADTOOLS PACS Framework components, and supports:

  • DICOM SCU Query/Retrieve, Store, Storage Commit

  • DICOM SCP service to provide Query/Retrieve and Store

  • DICOM Media import

  • Medical Image Viewing (display layouts, annotations, Zoom, Pan, Window-Level tools, etc)

  • User Access Control

  • 3D volume generation and viewing for DICOM series

This product includes:

LEADTOOLS Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS Web Viewer Framework

Additional Medical Imaging Features

DICOM Basic Features

DICOM Annotation Features

JPIP

This product is included with:

LEADTOOLS Medical Imaging Suite

The following LEADTOOLS products can be added to this product :

LEADTOOLS Medical Multimedia Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Barcode Modules

LEADTOOLS Virtual Printer Module

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


LEADTOOLS Multimedia

Available in LEADTOOLS Multimedia toolkits.

LEADTOOLS Multimedia ($595)

Price includes:

Development seat, application license, and unlimited internal deployment up to 5000 commercial deployments per year. Annual and fully paid licenses available for commercial deployment.

Platform Components:

C DLL API, COM Objects, and .NET classes

Product Description:

Create professional, high-quality multimedia applications encompassing everything from file conversion to video conferencing and streaming. The LEADTOOLS Multimedia SDK allows developers to add support for Capture, Play, Edit, conversion to and from many formats including AVI, MPEG-2 Program/Transport, MPEG-1, ISO (MP4, 3GPP, AAC, AVC1, MOV), XVID, WMV , WAV, WMA, OGG, and more. Also provided is the most comprehensive set of DirectShow filters which can be used for almost any multimedia processing task. The provided high level interface allows for programmatic control over multimedia processors, compressors, video and audio inputs, types and sub-types, video capture size, camera specific features (brightness, contrast, zoom, etc), and much more!

With LEADTOOLS Multimedia you get:

  • Multimedia Capture
    Create applications that can capture from WDM, native DirectShow including DV, and Video for Windows capture devices

  • Multimedia Playback
    Create applications that can play all formats supported by DirectShow, including DVDs and TV tuners

  • Multimedia Conversion
    Add features to your application so your users can convert to and from AVI, MPEG-2 Program/Transport, MPEG-1, ISO (MP4, 3GPP, AAC, AVC1, MOV), XVID, WMV , WAV, WMA, OGG, and many more.

  • Still Image Compression
    Add support to your application for compressing individual samples with any available DirectShow filters (Memory to memory).

  • Multimedia Processing
    Add to your applications the ability to process video and audio data from disk, memory, video devices, or streaming servers using the extensive set of provided DirectShow filters.

The LEADTOOLS Multimedia SDK includes a fully enabled development license for the following components:

DirectShow Filters

  • LEAD Video Add Filter

  • LEAD Video Auto Contrast Filter

  • LEAD Video Auto Intensity Filter

  • LEAD Video Auto Level Filter

  • LEAD Video EFX Brightness Filter

  • LEAD Video Color Filter

  • LEAD Video Color Replacement Filter

  • LEAD Video Deblocking Filter

  • LEAD Video Edge Enhance Filter

  • LEAD Video EFX Aging Filter

  • LEAD Video EFX Bump Map Filter

  • LEAD Video EFX Dizzy Filter

  • LEAD Video EFX Fire Filter

  • LEAD Video EFX Ghost Filter

  • LEAD Video EFX Glass Tile Filter

  • LEAD Video EFX Hologram Filter

  • LEAD Video EFX Lens Filter

  • LEAD Video EFX Lightning Filter

  • LEAD Video EFX Maze Filter

  • LEAD Video EFX Motion Blur Filter

  • LEAD Video EFX Motion Emboss Filter

  • LEAD Video EFX Motion Mosaic Filter

  • LEAD Video EFX Motion Scan Filter

  • LEAD Video EFX Particles Filter

  • LEAD Video EFX Predator Filter

  • LEAD Video EFX Rain Filter

  • LEAD Video EFX Streak Filter

  • LEAD Video EFX Wave Filter

  • LEAD Video Emboss Filter

  • LEAD Video Gamma Correction Filter

  • LEAD Video Mosaic Filter

  • LEAD Video RGB Converter

  • LEAD Video YUV Converter

  • LEAD Still Image Reader

  • LEAD Still Image Writer

  • LEAD Audio Callback Filter

  • LEAD Audio Chorus Filter

  • LEAD Audio Echo Filter

  • LEAD Audio Flanger Filter

  • LEAD Audio Phaser Filter

  • LEAD Audio Volume Control Filter

  • LEAD Audio VU Meter Filter

  • LEAD MPEG Audio Converter

  • LEAD Ogg Multiplexer

  • LEAD Ogg Splitter

Codecs

  • LEAD Vorbis Decoder

  • LEAD Vorbis Encoder

In addition, the toolkit includes evaluation versions of the above components, which can be licensed on an a la carte basis as-needed. For licensing and pricing information, contact oemsales@leadtools.com:

DirectShow Filters

  • LEAD Video Frame Rate Controller Filter

  • LEAD Video Histogram Equalize Filter

  • LEAD Video Histogram View Filter

  • LEAD Video Overlay Filter

  • LEAD Video Text Overlay Filter

  • LEAD Video Unsharp Mask Filter

  • LEAD Video Deinterlace Filter

  • LEAD Video Motion Detection Filter

  • LEAD Audio Detection Filter

  • LEAD Video Resize Filter

  • LEAD Video Crop Filter

  • LEAD Video Callback Filter

  • LEAD Video Rotation Filter

  • LEAD MPEG-1 Multiplexer

  • LEAD MPEG-2 Multiplexer

  • LEAD ISO Multiplexer

  • LEAD ISO Demultiplexer

  • LEAD MPEG2 Transport Demultiplexer

  • LEAD MPEG2 Program Demultiplexer

  • LEAD MPEG2 Transport UDP Source

  • LEAD DVD Writer for API

  • LEAD DVD Burner for API

  • LEAD DVD Control for API

  • LEAD Network Demultiplexer Filter for API

  • LEAD Network Multiplexer Filter for API

  • LEAD Network Sink Filter for API

  • LEAD Network Source Filter for API

  • LEAD DVD Writer for COM

  • LEAD DVD Burner for COM

  • LEAD DVD Control for COM

  • LEAD Network Demultiplexer Filter for COM

  • LEAD Network Multiplexer Filter for COM

  • LEAD Network Sink Filter for COM

  • LEAD Network Source Filter for COM

Codecs

  • LEAD MPEG Audio Converter

  • LEAD MPEG Audio Encoder

  • LEAD AAC Encoder

  • LEAD AAC Decoder

  • LEAD AC3 Encoder

  • LEAD AMR Encoder

  • LEAD AMR Decoder

  • LEAD H263 Decoder

  • LEAD H263 Encoder

  • LEAD H263 Encoder (VFW)

  • LEAD H264 Decoder

  • LEAD H264 Decoder (DMO)

  • LEAD H264 Encoder

  • LEAD H264 Encoder (DMO)

  • LEAD MCMW Decoder

  • LEAD MCMW Encoder

  • LEAD MCMP/MJPEG Codec (VFW)

  • LEAD MJ2K Decoder

  • LEAD MJ2K Encoder

  • LEAD MPEG-2 Decoder

  • LEAD MPEG-2 Encoder

  • LEAD MPEG-4 Decoder

  • LEAD MPEG-4 Encoder

  • LEAD Screen Capture Codec Filter (VFW)

  • LEAD Screen Capture Decoder

  • LEAD Screen Capture Encoder

  • LEAD MPEG Audio Encoder

This product is included with:

LEADTOOLS Medical Multimedia Module

The following LEADTOOLS products can be added to this product :

LEADTOOLS DVD Module

LEADTOOLS Video Streaming Module

LEAD MPEG-2 Transport Demultiplexer Modules

LEAD DVR Module

LEAD H.263 Video Codec

LEAD H.264 Video Codec

LEAD MJPEG2000 Video Codec

LEAD MPEG-2 Video Codecs

LEAD MPEG-4 Video Codecs

LEAD MCMW Video Codec

LEAD MCMP / MJPEG Video Codec

LEAD AAC Audio Codec

LEAD AMR Audio Codec

LEAD AC3 Audio Encoder

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS Raster PDF Read Plug-in*

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS Raster PDF Read Plug-in ($995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, AJAX, and COM Interoperability

Product Description:

The LEADTOOLS Raster PDF Read Plug-in supports loading, viewing, and rasterizing PDF, PDFA, Postscript, and EPS formats.

It integrates seamlessly with the broad imaging functionality available in LEADTOOLS toolkits, including specialized display, color-conversion, image-processing, scanning, annotations, and document clean-up.

Import and Loading Capabilities:

  • Loads PDF files up to version 1.6

  • Loads PostScript Language Level 3 files

  • Loads EPS files

  • Loading the entire document or a specified set of sequential pages

  • Decrypts RC4 40-bit and 128-bit key encryption

  • Supports User and Owner password permissions

Page Rasterization Controls:

  • Pixel Depths: 1-, 4-, 8-, and 24-pixel

  • Horizontal resolution: in dots per inch

  • Vertical resolution: in dots per inch

  • Fonts: System, or plug-in installed

  • Font anti-aliasing: 1-(none), 2-, and 4-bit

  • Graphics anti-aliasing: 1-, 2-, and 4-bit

This product includes support for:

Image Display

Color Conversion

Image Processing

Scanning / Screen Capturing

PDF

LEADTOOLS Raster PDF Read Plug-in is included in the following products:

LEADTOOLS Document Imaging Suite

This product may be added to:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Raster PDF Write Plug-in*

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS Raster PDF Write Plug-in ($995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

Full multi-page write support for PDF versions 1.4 (PDF/A) and 1.5, EPS, and Postscript formats is provided by the PDF Write module . Append, insert, replace and delete operations of specific pages within the generated PDF files is also supported.

It integrates seamlessly with the broad imaging functionality available in LEADTOOLS toolkits, including specialized display, color-conversion, image-processing, scanning, annotations, and document clean-up.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

Export/Saving Capabilities:

  • No compression, where the image is embedded inside the file without any compression.

  • Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

  • Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

  • Compressed using CCITT Group 4. For 1-bit images.

  • JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • JBIG2 compression. Bits per pixel: 1.

  • The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

  • None.

  • ASCII 85 text encoding algorithm.

  • ASCII HEX text encoding technique.

  • RC4 40- and 128-bit key encryption.

  • User and Owner password permissions.

This product includes support for:

Image Display

Color Conversion

Image Processing

Scanning / Screen Capturing

PDF

LEADTOOLS Raster PDF Write Plug-in is included in the following products:

LEADTOOLS Document Imaging Suite

This product may be added to:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Raster PDF Plug-ins

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS Raster Portable Document Format (PDF) Plug-ins

LEADTOOLS Raster PDF Plug-ins extend support to include PDF, Postscript, and EPS formats, providing capability for loading, saving, viewing, rasterizing, and encoding PDF, Postscript, and EPS files. The Plug-ins integrate seamlessly with the broad imaging functionality of LEADTOOLS toolkits, such as specialized display, color-conversion, image-processing, scanning, annotations, and document clean-up.

PDF has become a widely-adopted standard for reproducing documents over the web. Because of its high precision and accuracy in representing text and pictures along with its "hyper" nature, PDF has become a popular supplement or alternative to HTML and Postscript.

The PDF format was developed by Adobe Corporation to allow users to exchange and view electronic documents in an easy and reliable way, independent of the environment in which these documents were created. A PDF file looks the same on the screen and in print regardless of what kind of machine you are using, or which software package was used to create the file. One major advantage of PDF is that a large document can be compressed sufficiently for quick download, yet will display content as if you were looking at the original (print) source such as a book or magazine.

Postscript is a simple interpretive page description language. Postscript is the language that most advanced laser printers use in order to render electronic information on a printed page. EPS stands for Encapsulated PostScript. An EPS file is a PostScript language program describing the appearance of a single page.

Loading Capabilities

The LEADTOOLS Raster PDF Read plug-ins have the following import capabilities:

  • Loads essentially all PDF 1.6 files.

  • Loads PostScript Language Level 3 files.

  • Loads EPS files.

  • Load the entire document or a specified set of sequential pages.

Rasterization Capabilities

  • Control pixel depth - Valid values are 1,4,8 and 24.

  • Control horizontal resolution in dots per inch.

  • Control vertical resolution in dots per inch.

  • Use fonts installed by the plug-in or system fonts.

  • Font anti-aliasing - Valid values are 1-bit(no anti-aliasing) , 2-bit and 4-bit.

  • Graphics anti-aliasing - 1-bit , 2-bit and 4-bit.

Saving Capabilities

Full multi-page write support for PDF versions 1.4 (PDF/A) and 1.5 is provided by the PDF Write module . Append, insert, replace and delete operations of specific pages within the generated PDF files is also supported.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

  • No compression, where the image is embedded inside the file without any compression.

  • Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

  • Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

  • Compressed using CCITT Group 4. For 1-bit images.

  • JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • JBIG2 compression. Bits per pixel: 1.

  • The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

  • None.

  • Use ASCII 85 text encoding algorithm.

  • Use ASCII HEX text encoding technique.

Encryption/Decryption

  • RC4 40-bit key encryption.

  • RC4 128-bit key encryption.

  • Support for User password, Owner password permissions.

For background and full details, see:

http://www.leadtools.com/SDK/Raster/Raster-Addon-PDF.htm

LEADTOOLS PDF features are available in the following products:

LEADTOOLS Raster PDF Plug-in (Read)

LEADTOOLS Raster PDF Plug-in (Write)

LEADTOOLS_PDF_OCR_Plug-in

LEADTOOLS Recognition (PDF OCR Plug-in)

LEADTOOLS Document Imaging Suite (PDF OCR Plug-in + Raster PDF Plug-in Read/Write)

LEADTOOLS PDF Plug-ins may be added to the following:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging


LEADTOOLS Barcode Modules

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS Barcode Modules

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

LEADTOOLS Barcode features provide support for adding barcode recognition technology to applications developed with LEADTOOLS toolkits. LEADTOOLS Barcode Module functions allow you to read barcodes, write barcodes and find duplicate barcodes within an image.

LEADTOOLS barcode recognition is very fast; it outperforms most hardware-supported barcode read products. This software engine permits fast document scanners to maintain full speed while performing barcode recognition operations on the fly for document-indexing purposes.

Developers have the ability to provide optional configuration settings affecting the detection speed, including number of barcodes expected, barcode orientation, and potential location of barcodes. This flexibility in search parameters can improve the speed of barcode detection.

Supported barcode formats include Linear (1D), Data Matrix (2D), PDF417and MicroPDF417 (2D), and QR Code barcodes, including support for 95 different sub-types. This includes the ability to:

  • Read multiple barcodes at any orientation using a scanner or camera with frame-grabber.

  • High-speed barcode recognition. All barcodes in an image are located and reported back in fractions of a second. Accurate barcode reading and writing. Read colored barcodes.

  • Write barcodes to any supported raster image file or to any windows-compliant printer.

  • Encode thousands of characters per barcode symbol with 2D barcode technology.

  • Read barcodes from or write barcodes to selected regions of interest

  • Read and write barcodes with specified colors

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

  • Report comprehensive information with 100% confidence for all detected barcodes such as the barcode type, data string, location, check digit, etc.

  • Thread Safe for multithreaded applications.

  • Includes all popular barcode types.

When integrated with the extensive image processing technology available in LEADTOOLS toolkits, LEADTOOLS Barcode features make it possible to exert complete control over the barcode recognition process.

For background, full details, and a comparison chart showing features for each module, see:

http://www.leadtools.com/sdk/document/document-addon-barcode.htm

LEADTOOLS Barcode features are available in the following products:

LEADTOOLS 1D Barcode Module

LEADTOOLS 2D Barcode Module

LEADTOOLS Recognition (1D + 2D)

LEADTOOLS Document Imaging Suite (1D + 2D)

LEADTOOLS Barcode Modules may be added to the following products:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging


LEADTOOLS 1D Barcode Module

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS 1D Barcode Module ($695)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

The LEADTOOLS Linear 1D Barcode SDK is the most comprehensive read and write 1D barcode SDK available. LEAD's staff of barcode experts is constantly monitoring for new symbols to be added and researching new algorithms to make recognition more accurate and faster. Whether you need to read legacy Modified Plessey codes or prepare your applications for the 2010 global conversion from UPC and EAN symbols to GS1 DataBar symbols, LEADTOOLS has what you need.

Key Features:

  • Automatic barcode type detection

  • Read to/ write anywhere in the image or from region of interest.

  • Read in different directions such as horizontal and vertical.

  • Read skewed.

  • Very fast and accurate.

  • Read multiple barcode symbols anywhere in the image at any orientation.

  • Read mixed barcode types

  • Report back comprehensive information for all detected barcodes such as the barcode type, data string, X/Y position, bounding rectangle, check digit, etc.

  • Read colored barcodes.

  • Write barcode symbol with size, color and position parameters.

  • Support write/read RSS 14 and RSS 14 Expanded on multiple lines (Stacked version).

  • Check character handling.

  • Many optional settings give you complete control over your barcode recognition process.

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

Sub-types supported:

  • Airline Code 2 of 5

  • Australian Post 4-State

  • CODABAR

  • Code 3 of 9 (39)

  • Code 3 of 9 (39) Extended

  • Code 11

  • Code 32

  • Code 93

  • Code 93 Extended

  • Code 128

  • EAN 8

  • EAN 13

  • EAN EXT 2

  • EAN EXT 5

  • Interleaved Code 2 of 5

  • MSI (Modified Plessey)

  • Patch Code

  • Planet

  • PostNet

  • Royal Mail (RM4SCC)

  • USPS 4 State

  • RSS14/GS1 Databar Omnidirectional

  • RSS14/GS1 Databar Expanded

  • RSS14/GS1 Databar Expanded Stacked

  • RSS14/GS1 Databar Limited

  • RSS14/GS1 Databar Stacked

  • RSS14/GS1 Databar Stacked Omnidirectional

  • RSS14/GS1 Databar Truncated

  • Standard Code 2 of 5 (Industrial 2 of 5)

  • UCC EAN 128 (Read Only)

  • UPC A

  • UPC E

LEADTOOLS 1D Barcode Module is included in the following products:

LEADTOOLS Recognition (1D + 2D)

LEADTOOLS Document Imaging Suite (1D + 2D)

LEADTOOLS 1D Barcode Module may be added to the following products:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS 2D Barcode Module

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

LEADTOOLS 2D Barcode Module ($1495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

The LEADTOOLS 2D Barcode SDK is the most comprehensive read and write 2D barcode SDK available. LEAD's staff of barcode experts is constantly monitoring for new symbols to be added and researching new algorithms to make recognition faster and more accurate.

This product includes support for the following features:

LEADTOOLS Data Matrix

LEADTOOLS Barcode 2D PDF 417

LEADTOOLS Barcode QR Code

LEADTOOLS 2D Barcode Module is included in the following products:

LEADTOOLS Recognition (1D + 2D)

LEADTOOLS Document Imaging Suite (1D + 2D)

LEADTOOLS 2D Barcode Module may be added to the following products:

L EADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS CCOW Module

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS CCOW Module ($495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

.NET classes

Product Description:

LEADTOOLS CCOW SDK functionality encapsulates HL7's vendor independent Context Management Architecture standards. Context Management is a dynamic computer process that uses 'subjects of interest' in one application, to point to data resident in a separate application also containing the same subject. Incorporating Clinical Context Object Workgroup (CCOW) interface standards into the LEADTOOLS PACS Framework Imaging enables developers to link and synchronize applications. Applications share information so that they appear to behave as a single system: creating the illusion of a single authenticated system at point-of-use, rather than disparate applications from multiple vendors.

The LEADTOOLS CCOW SDK contains classes, properties, methods and events that implement:

  • Context participants

  • Context managers

  • Mapping agents

  • Authentication repository

For more information about this product, see:

This product is included with:

LEADTOOLS Medical Imaging Suite

LEADTOOLS CCOW may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging


LEADTOOLS OCR Modules

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR / MICR Modules

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

LEADTOOLS OCR engines extend the functionality of LEADTOOLS SDKs by providing properties, methods, and events for easily incorporating optical character recognition into your applications. Since superior OCR processing speeds are exceptionally useful in form recognition and processing applications, LEAD has designed our OCR engines to support both 32 and 64 bit environments, as well as multithreaded applications. When used in conjunction with LEADTOOLS extensive set of document cleanup and image processing functions (often necessary for scanned and faxed images), OCR results are vastly improved.

Features include preset confidence and accuracy levels, artificial intelligence, and built-in and user-defined lexicons for limiting the type of text to recognize within a particular zone. The OCR engines can perform automatic area segmentation to create multi-layered zones for recognition of areas such as tables, rules, images and text. Alternatively, you can manually designate up to 250 such zones.

The OCR Engine supports multiple fonts, sizes (5 to 72 point) and styles for all major European and Scandinavian languages (Danish, Dutch, Finnish, French, German, Italian, Norwegian, Portuguese, Russian, Spanish, and Swedish) as well as English and MICR (Magnetic Ink Character Recognition). Support for dialects such as US. English, French Canadian, Latin American Spanish, Swiss German, and Brazilian Portuguese is also provided.

LEADTOOLS provides multiple OCR Engines to meet the needs of every Document Imaging solution. The high level .NET OCR interface allows developers to create applications which support any of the offered OCR engines without having to change recompile or change any code!

Recognized text can be exported to more than 40 different formats, including MS Word, PDF/A, MS Excel, XML, RTF, TEXT, HTML, and more.

Key Features:

  • Recognize and export text, choosing from a variety of text, word processing, database, or spreadsheet file formats.

  • Select the language of documents to be recognized. Choose from English, Danish, Dutch, Finnish, French, German, Italian, Norwegian, Portuguese, Russian, Spanish, Asian (Professional Engine Only), or Swedish.

  • Recognize special characters, such as MICR (Magnetic Ink Character Recognition), including bank routing indicators, check amounts, and customer account numbers.

  • Segment complex pages manually or automatically into text zones, image zones, table zones, lines, headers and footers.

  • Set accuracy thresholds prior to recognition to control the accuracy of recognition.

  • Recognize text from 5 to 72 points in virtually any typeface.

  • Increase recognition accuracy with built-in lexical classes and user-defined lexicons (dictionaries)

  • Verify or correct text during the recognition process based on confidence levels set prior to recognition. If a word or character falls within the set range, a dialog box can be brought up to allow the user to see the original image and the preliminary results of the recognition. From the dialog box, the user may make any necessary corrections to the recognized text.

  • Automatically detect fax, dot matrix, and other degraded documents and compensate accordingly.

  • Process both text and halftone graphics. The recognition software's ability to distinguish halftone graphics from text can provide the basis of a compound document processing system.

  • Recognize text and colors within tables.

  • Export recognized text to more than 40 different formats, including MS Word, PDF/A, MS Excel, XML, RTF, TEXT, HTML, and more..

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR features are available in the following products:

LEADTOOLS OCR Advantage

LEADTOOLS OCR Plus

LEADTOOLS OCR Professional

LEADTOOLS PDF OCR Module

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS OCR Arabic

LEADTOOLS OCR Module with Asian Languages - Professional

LEADTOOLS OCR Modules may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OCR Advantage

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR Advantage Module ($995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

.NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS OCR Advantage module provides functions, properties, methods, and events for easily incorporating automatic and manual zone detection, formatted output, auto-orientation, and custom spelling dictionaries support into your applications. PDF and PDF/A output and OMR support is also available.LEADTOOLS OCR Advantage module is included in LEADTOOLS Recognition SDK and LEADTOOLS Document Imaging Enterprise SDK.

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR Advantage Module is included in the following products:

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS OCR Advantage Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OCR Plus

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR Plus Module ($1495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS OCR Plus module provides functions, properties, methods, and events for easily incorporating automatic and manual zone detection, formatted output, auto-orientation, custom spelling dictionaries and MICR (magnetic ink character recognition) support into your applications. PDF and PDF/A output, as well as ICR and OMR support are also available.

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR Plus Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OCR Professional

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR Professional Module ($1995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS OCR Professional module provides functions, properties, methods, and events for easily incorporating the fastest and most accurate automatic and manual zone detection, Unicode support, formatted output, auto-orientation, custom spelling dictionaries and MICR (magnetic ink character recognition) support into your applications. PDF and PDF/A output, as well as ICR and OMR support is also available. The Professional Engine also adds Asian to the list of supported OCR languages.

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR Professional Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS PDF OCR Plug-in*

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS PDF OCR Module ($1495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS PDF OCR Module allows programmers to easily include code in their applications to output recognized text to the PDF after performing OCR or ICR on document files. Supported output types include PDF, PDF/A, PDF (Image over text), and PDF (Text only).

LEADTOOLS PDF OCR Module is included in the following products:

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS PDF OCR Module may be added to the following products (requires OCR Engine):

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OCR Arabic

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR Arabic Module ($5995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS OCR Arabic module provides functions, properties, methods, and events for easily incorporating automatic and manual zone detection, formatted output, auto-orientation, custom spelling dictionaries and MICR (magnetic ink character recognition) support into your applications. PDF and PDF/A output, as well as ICR and OMR support are also available.

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR Arabic Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OCR Module with Asian Languages - Professional

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OCR Module with Asian Languages - Professional ($4995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS OCR Module with Asian Languages - Professional provides functions, properties, methods, and events for easily incorporating automatic and manual zone detection, formatted output, auto-orientation, custom spelling dictionaries and MICR (magnetic ink character recognition) support into your applications. PDF and PDF/A output, as well as ICR and OMR support are also available.

This module includes both Latin and Asian OCR.

For background, product comparison chart, and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OCR.htm

LEADTOOLS OCR Module with Asian Language - Professional may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS ICR Module

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS ICR Modules

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

LEADTOOLS ICR (Intelligent Character Recognition) modules provide functions, properties, methods, and events for converting handwritten text and numbers into machine readable strings and documents, and can be used in the same fashion and mixed on the same image as the OCR modules.

The LEADTOOLS ICR module supports hand written text in nearly 100 languages including 15 with dictionary support.

Key Features:

  • HNR: The hand-printed numeral recognition engine is designed for speed and accuracy, using a reduced character set. It is specialized to recognize the following:

  • digits (0-9)

  • plus sign (+)

  • minus sign (-)

  • period or full-stop (.)

  • comma (,)

  • comma (,)

  • RER: The alphanumeric hand-print recognition engine is designed to recognize upper and lower case text, numbers and symbols.

  • Export to over 40 output formats.

  • Use in the same fashion as the OCR module.

  • Mix different recognition modules (including the OCR module) on the same image

  • Specify a different recognition module for each zone in the same page.

  • Improve recognition results with dictionaries, available in the following languages:

Catalan

Czech

Danish

Dutch

English

Finnish

French

German

Hungarian

Italian

Norwegian

Polish

Portuguese

Spanish

Swedish

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-ICR.htm

LEADTOOLS ICR features are available in the following products:

LEADTOOLS ICR Plus

LEADTOOLS ICR Professional

LEADTOOLS ICR Modules may be added to the following products (requires corresponding OCR Engine):

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS ICR Plus

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS ICR Plus Module ($2995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS ICR Plus module provides functions, properties, methods, and events for easily incorporating intelligent character recognition into your OCR applications.

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-ICR.htm

LEADTOOLS ICR Plus Module may be added to the following products (requires corresponding OCR Engine):

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS ICR Professional

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS ICR Professional Module ($3995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

The LEADTOOLS ICR Professional module provides functions, properties, methods, and events for easily incorporating the fastest and most accurate intelligent character recognition engine into your OCR applications.

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-ICR.htm

LEADTOOLS ICR Professional Module may be added to the following products (requires corresponding OCR Engine):

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS OMR Module

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OMR Module ($795)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, .NET Classes, WCF Services, and Windows Workflow

Product Description:

LEADTOOLS OMR (Optical Mark Recognition) Module extends the functionality of LEADTOOLS SDKs by providing properties, methods, and events for easily incorporating fast, automated, and accurate optical mark recognition into your application. Optical Mark Recognition is used in surveys, polls, academic exams and official applications, to recognize the bubbles that the applicant fills in to indicate their selections. Supported marks include tick marks, X's, lines, checkmarks, and scribbles. Supported shapes (or frames) include boxes, circles and ellipses.

OMR is automated, very fast and accurate. It also has multiple options for different types of applications.

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OMR.htm

LEADTOOLS OMR Module is available in the following products:

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS OMR Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Medical Multimedia Module

Available as an Add-on to LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical Multimedia Module ($995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone licenses available.

Platform Components:

C DLL, COM

Product Description:

The LEADTOOLS Medical Multimedia Module includes a full Multimedia development toolkit, MPEG-2, Motion JPEG, and JPEG2000 DirectShow filters, and DICOM DirectShow Read and Write filters.

The DICOM File Reader Filter provides the ability to ability for any DirectShow based media player or application to play, cine, or convert any DICOM file with standard DICOM video compressions including MPEG-2, lossy and lossless JPEG, and JPEG2000. This filter offers basic stream and frame rate control functionality, as well as the ability to insert a user-defined external DICOM dataset and obtain access to the initialized dataset for use with other processes.

The DICOM File Writer Filter provides the ability to create DICOM files with both video and audio using MPEG-2, Motion JPEG, and JPEG2000 compression, while allowing the user to adjust the different attributes of the video stream including bit rate and quality factor. Video data can be added to existing DICOM files, as well as new files created from a set of predefined DICOM classes or IODs. When used in conjunction with LEADTOOLS Medical Imaging SDK's, developers have all the tools necessary to create powerful medical applications for creating, editing, and viewing DICOM files.

For more information on this product, please see:

LEADTOOLS Medical Multimedia Module Features

This product is included with:

LEADTOOLS Medical Imaging Suite

This product includes:

LEADTOOLS Multimedia SDK

LEAD MPEG-2 Video Codecs

LEAD MCMP / MJPEG Video Codec

LEAD DICOM Reader Filter

LEAD DICOM Writer Filter

This product may be added to:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables Redistributables | Documentation | Support | Licensing


LEADTOOLS Medical 3D Module

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical 3D Module ($3995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

.NET classes

Product Description:

The LEADTOOLS Medical 3D Module contains classes, properties, methods and events that make it possible to generate 3D models from image files. These can be used in medical, scientific, and industrial imaging applications.

For more information about this product, see:

This product is included with:

LEADTOOLS Medical Imaging Suite

LEADTOOLS Medical 3D may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging


LEADTOOLS DVD Module

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEADTOOLS DVD Module ($295)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL API and COM Objects

Product Description:

The LEADTOOLS DVD Module extends the LEADTOOLS Multimedia toolkit by adding functionality for programmatically creating DVD images. The DVD images created can then be played back using DVD player software or burned to DVD for playback using a DVD player or drive. The LEADTOOLS DVD Module has everything you need to create and burn DVD images, including a DVD writer (create images), DVD burner, MPEG-2 and MPEG-1 multiplexers, MPEG Audio encoder, LEAD MPEG-2 Standard video codec (Encoder/Decoder), and several DirectShow filters to resize and crop videos, as well as filters to convert video color spaces.

Key Features and Components:

  • DVD Support

    • Play DVD

    • Create DVD Image

    • Burn DVD/ISO Image

    • DVD Burner Demo

  • DVD Filters

    • LEAD DVD Writer Filter

    • LEAD DVD Burner Filter

    • LEAD DVD Control

  • MPEG Multiplexers

    • LEAD MPEG-1 Multiplexer

    • LEAD MPEG-2 Multiplexer

  • Codecs

    • LEAD MPEG Audio Encoder

    • LEAD MPEG-2 Decoder

    • LEAD MPEG-2 Encoder

  • Direct Show Filters

    • LEAD Video Frame Rate Controller Filter

    • LEAD Video Deinterlace Filter

    • LEAD Video Resize Filter

    • LEAD Video Crop Filter

    • LEAD Video Rotation Filter

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.

For more information about this product, see:

http://www.leadtools.com/SDK/Multimedia/dvd-imager-sdk.htm

This product may be added to:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS Video Streaming Module

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEADTOOLS Video Streaming Module ($295)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL API and COM Objects

Product Description:

The LEADTOOLS Video Streaming Module is perfect for developers who need to serve Videos on Demand, offering an unsurpassed multimedia experience while at the same time reducing bandwidth requirements. You can serve multimedia files via a standard IIS web server or with Microsoft Media Server using our H264 DMO Codec. The LEADTOOLS Video Streaming Module is designed to provide you with all the tools you need to provide streaming multimedia content via the web. It enables you to create applications that can capture from WDM, native DirectShow including DV, Video for Windows capture devices, and other sources.

It is also possible to create custom video conferencing applications and utilities. The LEADTOOLS Video Streaming Module can be used to create Client/Server applications such as:

  • Security Server / WebCast: Where a single server is sending to multiple clients

  • Video Conferencing: Where each computer participating in the conference is both a client and a server

  • Live Presentations over the Web: Where screen activity on a server is captured and sent to one or more clients

  • Web TV Streaming: Where an application running on a server captures live TV content and streams it to the client, while allowing the client full control over the source.

Key Features:

  • Network filters and objects

  • LEAD ISO Demultiplexer

  • LEAD ISO Multiplexer

  • LEAD Network Demultiplexer Filter for AP

  • LEAD Network Multiplexer Filter for API

  • LEAD Network Protocol Manager

  • LEAD Network Sink Filter for API

  • LEAD Network Source Filter for API

  • LEAD Network Demultiplexer Filter for COM

  • LEAD Network Multiplexer Filter for COM

  • LEAD Network Protocol Manager

  • LEAD Network Sink Filter for COM

  • LEAD Network Source Filter for COM

  • LEAD Network Demultiplexer Filter for COM

  • LEAD Network Multiplexer Filter for COM

  • LEAD Network Protocol Manager

  • LEAD Network Sink Filter for COM

  • LEAD Network Source Filter for COM

  • Codecs

  • LEAD H264 Decoder

  • LEAD H264 Decoder (DMO)

  • LEAD H264 Encoder

  • LEAD MPEG-4 Decoder

  • LEAD MPEG-4 Encoder

  • LEAD AAC Encoder

  • LEAD AMR Encoder

  • LEAD AMR Decoder

  • Video Post Processing Filters

  • LEAD Video Frame Rate Controller Filter

  • LEAD Video Deinterlace Filter

  • LEAD Video Resize Filter

  • LEAD Video Crop Filter

  • LEAD Video Rotation Filter

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.

For more information about this product, see:

http://www.leadtools.com/SDK/Multimedia/video-ondemand-sdk.htm

This product may be added to:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS MPEG-2 Transport Demultiplexer

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEADTOOLS MPEG-2 Transport Module ($1995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL API and COM Objects

Product Description:

LEAD MPEG-2 Transport Module includes DirectShow filters that allow you to play MPEG-2 Transport and MPEG-2 Program files from a file or from a UDP stream. With used in conjunction with LEADTOOLS DVR Module, developers can create applications which can pause, rewind, and fast forward into live streaming video content. It can also stream data from a RTSP server.

For applications such as satellites and UAVs (Unmanned Aerial Vehicle), the LEADTOOLS MPEG-2 Transport Module supports the creation and parsing of any KLV data to create implementations of specifications such as:

  • UAV Datalink Local Metadata Set (EG 0601 12 Jan 2006)

  • Predator UAV Basic Universal Metadata Set (MISB EG 0104.4 25 August 2005)

Key Features:

  • Play MPEG-2 transport streams.

  • Play MPEG-2 Program files without using the Microsoft demuxers: In particular, you can use this demuxer to play correct DICOM MPEG-2 files, which use MPEG-2 Video and MP3 audio.

  • Receive streaming MPEG-2 data through UDP ports.

  • Retrieve the private data (especially the KLV data) from a stream.

  • Parse the private data (simplifying the process of interpreting the private data).

  • Play all compressions supported by MPEG-2 transport format (ISO/IEC 13818-1)

  • Video:

    • MPEG-2

    • MPEG-4

    • H.264

  • Audio:

    • MPEG1 Layer 1, 2, 3

    • AAC

    • AC3 (Requires a AC3 audio decoder)

    • LPCM (Requires a LPCM audio decoder)

    • Play the following compressions from a RTSP server:

      • Video:

        • H.264

        • MJPEG

      • Audio:

        • AAC

For more information about this product, see:

http://www.leadtools.com/SDK/Multimedia/mpeg2-transport-stream.htm

This product includes:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS DVR Module

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEADTOOLS DVR Module ($295)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL API and COM Objects

Product Description:

The LEADTOOLS DVR Module allows developers to pause, rewind, and fast-forward live streams. Typical sources could be live TV streams, live MPEG2 Transport data streaming or UDP/TCP, or WMV streams. Additionally, developers can copy or convert the buffer to another format or DVD. The DVR module supports MPEG-2 Program streams and MPEG-2 Transport stream support is also available. This module consist of two main components:

LEAD DVR Sink

LEADTOOLS DVR Sink filter uses LEAD intelligent time-shifting algorithm to write live video/audio streams to disk for playback. Complete control of the buffer size is providing including support to have the buffer span more than one disk. This filter should be used in conjunction with the LEADTOOLS DVR Source filter.

LEAD DVR Source

LEADTOOLS DVR Source filter is used to read video and audio streams from files created by the LEADTOOLS DVR Sink filter. This filter allows the LEADTOOLS Player control to play, pause, rewind, and fast forward live streams.

Key Features and Components:

  • DVR Support

    • Pause, Rewind, Fast Forward live streams

    • Complete control of disk buffer size

  • DVR Filters

    • LEAD DVR Sink Filter

    • LEAD DVR Source Filter

  • MPEG Multiplexers / Demultiplexor

    • LEAD MPEG-1 Multiplexer / Demultiplexor

    • LEAD MPEG-2 Program Multiplexer / Demultiplexor

  • Codecs

    • LEAD MPEG Audio Encoder

    • LEAD MPEG-2 Decoder

    • LEAD MPEG-2 Encoder

    • LEAD Screen Capture Encoder and Decoder

  • Direct Show Filters

    • LEAD Video Frame Rate Controller Filter

    • LEAD Video Deinterlace Filter

    • LEAD Video Resize Filter

    • LEAD Video Crop Filter

    • LEAD Video Rotation Filter

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.

For more information about this product, see:

http://www.leadtools.com/SDK/Multimedia/dvr.htm

This product may be added to:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEADTOOLS ePrint

LEADTOOLS ePrint Professional $99

(Contains the Driver, API and COM Objects)

LEADTOOLS ePrint Professional is an image/file converter that allows you to convert your images or documents from any Windows application to over 150 file types including searchable PDF, DOCUMENT, TIFF, JPEG, etc., as easily as printing the file. Set up multiple ePrint printers with different settings so that you can easily handle your workflow in the most efficient manner. LEADTOOLS ePrint includes print redirection to any of the over 150 supported image and document formats, broadcast printing to print to more than one printer at a time, and enhanced printing to add advanced printing features.

LEADTOOLS ePrint makes conversion to searchable PDF easier from any of your applications. It includes more PDF options than ever, like Font Embedding, Unicode Support, Bookmarks, Watermarks, Security, Compression, and more.

This product contains part of the following feature:

Printing


ePrint Terminal Server

ePrint Terminal Server* ($1995)

(ePrint TS)

ePrint Terminal Server Edition is perfect for companies needing to purchase multiple copies of ePrint without the hassle of installing it on each individual employee's computer. ePrint TS provides system administrators with a centralized location for ePrint software installation as well as updates and upgrades.

You get all the great features of ePrint 5: file conversion/creation, broadcast printing, document merging, and more--without the extra work of maintaining it on multiple client machines! For example, if your company has its headquarters in Chicago but also has offices in Phoenix, Baltimore and New Jersey, you can install ePrint TS at one central office but users at all locations will be able to use it without having to actually install the software.

ePrint TS has a 'Users Manager' which allows the system administrator to add, find, delete or modify users. The number of users added depends on the number of licenses you have purchased.

ePrint TS can be installed on Microsoft Windows 2000 Server and later (with terminal services installed), with and without Citrix.

*Includes one server license and one user license. A license is required for each individual user of the Terminal Server Edition.

Note: ePrint Terminal Server edition can be also be purchased in combination with ePrint API for $3495, saving $250 over buying each product separately. The combination includes the API and one server license.


ePrint OEM

ePrint SDK (API and COM) ($1750)

(API and COM Objects)

The ePrint API and COM SDK lets you interact with the LEADTOOLS ePrint driver from your own applications or third party applications.

LEADTOOLS also provides OEM support for the ePrint SDK, which lets you customize the ePrint user interface for your application. The purchase price includes 50 user licenses.

The ePrint SDK provides properties, methods and events for controlling or modifying the following ePrint Professional properties:

  • Printer Name

  • Driver Name

  • Monitor Name

  • Port Name

  • Product Name

  • Serial Number

  • Registry Subkey

  • Root Directory

  • Help File Name

  • Available Paper Sizes

  • Available X and Y Resolutions

  • Hide/Show Option Tabs

  • About String

  • About Icons

  • Save Format Types

  • Vector

  • Raster

  • Document

  • Save Output Formats

  • TIFF

  • JPEG

  • 150+ other file formats

  • Email Configuration

  • Sender Name

  • Sender Address

  • Reply To Address

  • SMTP Server

  • User Name

  • Password

  • Server Time Out

  • Port

  • Requires Authentication

Note: The ePrint API and COM SDK can be also be purchased in combination with ePrint Terminal Server Edition for $3495, saving $250 over buying each product separately. The combination includes the API, COM Objects, and one server license.


LEADViEW

LEADViEW ($19.95)

LEADViEW is an easy-to-use, yet powerful and full-featured image editor. With LEADViEW, you can create, modify, enhance, and retouch images. Use LEADViEW to:

  • Import/capture images from TWAIN scanners, digital cameras, digital video cameras, or screen.

  • Save or convert images to numerous Files and File Formats.

  • Process images for color correction and enhancement using a wide variety of filters and over 48 special effects.

  • Edit or retouch images with powerful painting and drawing tools.

  • Print and composite images using an interactive visual print layout system.

  • Use WYSIWYG Print Preview that can change the size, orientation and position of the image on the fly.

  • Manage photos using LEAD Photo Album.

  • Generate image-maps for use in web pages, using a visual image-map editor.


LEAD H.263 Video Codec

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD H.263 Video Codec

H.263 is an ITU standard, designed for low bit rate communications such as video-conferencing and video-telephony applications. At the same time it can be used for a wide range of bit rates and not just low bit rates. H.263 is a hybrid of interframe compression that makes use of temporal redundancy and intraframe transform coding to use spatial redundancy as a compression advantage. Accordingly, a superior compression ratio can be achieved in comparison to other video codecs.

The LEAD H.263 codec is a high quality lossy interframe DirectShow and Video for Windows (VfW) codec with a quality and compression ratio comparable to MPEG-4. It is used in a range of applications including video-conferencing, Internet video (Flash Video), surveillance and monitoring, and it is also supported by my mobile phones and devices. The LEAD H.263 codec is suitable for videos captured from cameras as well as video screen captures. This video codec registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow and Microsoft Video for Windows®. Existing video software, such as Windows® Media Player® and Ulead Media Studio® can utilize this codec to play, create, convert and edit.

Key features of the LEAD H.263 Video Codec:

  • Interframe compression comparable to MPEG-4.

  • Rate control algorithm based on the TMN8 which is suitable for videophone applications.

  • The encoder accepts RGB24 and RGB32 formats.

  • Decoder can produce RGB24, RGB32 YUY2, RGB555 and RGB565 formats.

  • Codec implements all elements and functionality of ITU-T H.263+, plus

  • Deblocking Filter Mode (Annex J).

  • Unrestricted Motion Vector (Annex D).

  • Advance Intra Coding Mode (Annex I)

  • Advance Prediction Mode (Annex F)

  • Modified Quantization Mode (Annex T)

  • Alternative Inter VLC Mode (Annex S)

  • Supports any video dimension.

  • Employs half pixel precision for motion compensation.

  • Unrestricted motion vectors.

This product includes parts of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-h263-codec.htm/a>

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trade mark or a registered trademark of Microsoft Corporation.

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD H.264 Video Codecs

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD H.264 Video Codec

H.264 is a high quality video compression algorithm and is suited for all types of applications with different ranges of bit rates. H.264 compressed video data can be stored inside a variety of video formats including AVI, MPEG2 Transport, ISO (MP4 and MOV), OGG, and Windows Media with the option of saving the file with or without the audio data.

LEAD H264 Video Codec is a state-of-the-art DirectShow filter for compressing and decompressing video data using H.264/AVC standard. H.264 is the latest and most advanced video standard developed jointly by ITU and MPEG. H.264/AVC provides a far more efficient algorithm for compressing video than any other compression method available. It typically outperforms all existing standards by a factor of three to four especially in comparison to MPEG-2. To meet the quality, resolution, and performance demands of todays multimedia industry, LEAD has also optimized our H264 Codec to utilize multiple threads on multi-core machines. LEADTOOLS has also extended the H264 standard by offering a "Super Compression" option which out performs standard H264 compression in file size, quality, and CPU performance. Files created using LEAD's "Super Compression" option can be decoded by any H264 standard Decoder.

Key features of the LEAD H.264 Video Codec:

  • User-definable motion estimation settings control the balance between encoder speed and quality.

  • The LEAD H.264 encoder makes use of the SAD HADAMARD calculation to increase the compression ratio.

  • "Super Compression" option for maximizing performance and quality, while minimizing file size.

  • Ability to encode and decode in multiple threads.

  • Multiple reference frames of any combination of past and future frames, provides precise interprediction as well as improved robustness during packet loss while streaming over the network or Internet.

  • Unrestricted motion search uses reference frames that may be partly outside the frame improving network performance by predicting missing data.

  • Only the difference between motion vectors is saved, increasing the compression ratio.

  • Intraprediction may be performed either on 4x4 blocks or 16x16.

  • Motion vector prediction is performed before the frame is prepared for compression (pre-DCT) improving prediction and compression performance.

  • Computation is more efficient because LEAD implements the traditional Discrete Cosine Transform (DCT) as an integer transform.

  • A context-sensitive deblocking filter smoothes out internal edges, significantly improving the visual quality of the video. The filter strength depends upon the prediction modes and relationship between the neighboring blocks.

  • Employs Context-Adaptive Variable Length Coding (CAVLC) to encode transform coefficients.

  • The Context-Adaptive Binary Arithmetic Coding (CABAC) method continually updates frequency statistics of the incoming data and adaptively adjusts the algorithm, improving compression performance.

  • The LEAD H.264 encoder provides the user control of the number and types of frames encoded into the video stream.

    • What do Encoder and Decoder mean?

    A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

    This product includes parts of the following features:

    Image Compression

    Files and File Formats

    For more details on this product, refer to:

    www.leadtools.com/SDK/Multimedia/Multimedia-h264-codec.htm

    This product may be added to:

    LEADTOOLS Multimedia

LEADTOOLS H.264 Video Codec is included in the following products:

Video Streaming Module

MPEG2 Transport Module

LEADTOOLS H.264 Video Codec may be added to the following products:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD_MJPEG2000_Codec

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD MJPEG2000 Video Codec

JPEG2000 provides high compression with image quality superior to all existing standard encoding techniques. This high compression and quality performance is due to the adaptation of wavelet transforms.

What is MJ2K?

MJPEG2000 or MJ2K is a video adaptation of the JPEG2000 standard for still photos. It treats a video stream as a series of still photos, compressing each individually, with no interframe compression. Because it uses no interframe compression, it is ideal for editing. The JPEG2000 standard is the official successor to JPEG and will eventually replace the older JPEG standard for high-quality image compression.

The LEAD MJPEG2000 video codec saves standard JPEG2000 streams. This codec is perfect when high compression and interoperability are necessary. This video codec registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard motion JPEG2000.

Key features of the LEAD MJPEG2000 Video Codec:

  • J2K offers higher compression efficiency than JPEG with less visual loss especially at extreme compression ratios.

  • Is built to the JPEG2000 standard of compression for maximum interoperability.

  • A single code stream that offers both lossy and superior lossless compression.

  • Better transmission in noisy environments. Designed to avoid catastrophic decoding failure due to bit errors from transmission.

  • Supports 16-bit grayscale video.

What do Encoder and Decoder mean?

A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

This product includes parts of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-MJPEG2000-codec.htm

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trademark or a registered trademark of Microsoft Corporation.

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD MPEG-2 Video Codecs

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD MPEG-2 Video Codecs

MPEG-2 is a high quality video compression and is primarily targeted for applications that require higher bit rates or high bandwidth usage: most commonly, DVD videos, Super VCD (SVCD), box top DVR's and digital television.

The LEAD MPEG-2 decoder supports several levels and profiles. Levels (source formats) supported range from Limited Definition (VCR quality) to full HDTV - each with a range of bit rates. In addition to this flexibility in source formats, the LEAD MPEG-2 codec supports several different profiles. Each profile offers a different set of compression tools that together make up the coding system.

Key features of the LEAD MPEG-2 Video Codec:

  • MPEG-1 and MPEG-2 output stream.

  • Low, main & high profiles implementation.

  • Inter-prediction accuracy of 1/2 pixel.

  • Preprocessing frame-rate adjustment.

  • Fixed and variable bit rate compression options, with a wide range of quality factors.

  • Preset compression options for DVD, VCD, SVCD and DICOM.

LEAD's MPEG-2 video codec is a multimedia compressor / decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard (ISO/IEC 13818-2) MPEG-2 streams.

What do Encoder and Decoder mean?

A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

This product includes parts of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-mpeg2-codec.htm

This product is included with:

LEADTOOLS Medical Multimedia Module

LEADTOOLS DVD Module

LEADTOOLS MPEG2 Transport Module

LEADTOOLS DVR Module

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trademark or a registered trademark of Microsoft Corporation.

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD MPEG-4 Video Codecs

The LEAD MPEG-4 Video Codecs feature LEAD's iCompress™ Technologies and use a high quality video compression algorithm suitable for all types of applications with different ranges of bit rates. In addition to ISO (MP4) files, MPEG-4 compressed video data can be stored inside MPEG2 Transport, AVI, or OGG files with the option of saving the file with or without the audio data.

Key Features:

  • Supports linear and nonlinear quantization.

  • Supports frame rate adjustment.

  • Delivers the following output formats; MP4V (standard), IPOD compatible, XVID, and LMP4. LMP4 is LEAD’s proprietary MPEG-4 video. With LMP4, a super compression option can be used to achieve higher compression while maintaining quality.

  • Configurable motion estimation.

  • LEAD MPEG-4 Encoder includes LEAD AAC Encoder and ISO Multiplexer.

  • LEAD MPEG-4 Decoder includes LEAD AAC Decoder and ISO De-multiplexer.

  • Variable or constant bitrate, or constant quality encoding options.

LEAD's MPEG-4 video codec is a multimedia compressor / decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard (ISO/IEC 14496-2) MPEG-4 streams.

What do Encoder and Decoder mean?

A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

This product includes parts of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-mpeg4-codec.htm

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trademark or a registered trademark of Microsoft Corporation.

For more details on this product, refer to:

www.leadcodecs.com/Codecs/LEAD-MPEG-4.htm

LEADTOOLS MPEG-4 Video Codec is included in the following products:

Video Streaming Module

MPEG2 Transport Module

LEADTOOLS MPEG-4 Video Codec may be added to the following products:

LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD Video Codec (MCMW)

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD MCMW Video Codec

LEAD's MCMW Video Codec is a wavelet based multimedia compressor/decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit LEAD's proprietary MCMW video streams. Developed by LEAD as an alternative to standard compression algorithms, MCMW delivers smaller file sizes and can maintain better image quality than any standard compression with better image quality.

The MCMW Video Codec is designed to meet the needs of high-quality video compression using low bandwidth (dial-up) delivery. This is achieved by using a state of the art intra-frame wavelet based compression technique that provides superior compression performance, while still ensuring optimal quality at any given compression. This makes the MCMW Video Codec an ideal candidate for video editing, video conferencing, remote monitoring and video storage.

Key features of LEAD Video CMW Video Codec:

  • Create significantly smaller AVI files.

  • Create, edit and playback video using existing applications.

  • Create smaller files but with better image quality.

  • Use a wide range of compression ratios.

  • Exert precise rate control.

W hat do Encoder and Decoder mean?

A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

This product includes parts of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-MCMW-codec.htm

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trademark or a registered trademark of Microsoft Corporation.

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD Video Codec (MJPEG / MCMP)

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD MCMP / MJPEG Video Codec

Because of LEAD's MCMP/MJPEG video codec's real time compression and decompression, random access to every frame, support of creating a losslessly compressed stream, this codec is flexible enough to meet the requirements of a wide range of applications.

Offering standard and proprietary compression options, LEAD's MCMP / MJPEG Video Codec is a multimedia compressor / decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow and Microsoft Video for Windows®. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard MJPEG and LEAD's proprietary MCMP files. Developed by LEAD as an alternative to standard compression algorithms, MCMP delivers smaller file sizes and can maintain better image quality than MJPEG with the same or better image quality.

Key features of the LEAD MCMP-MJPEG Video Codec:

  • Real-time software-only compression and decompression of full motion video.

  • Significantly smaller AVI files.

  • Preserve critical image data with lossless compression.

  • Create, edit and playback video using existing applications.

  • Smaller file size, better image quality option.

  • Read/write hardware compatible MJPEG files.

  • Supports 16-bit grayscale video.

What is MJPEG?

Motion JPEG, or MJPEG, is a video adaptation of the JPEG standard for still photos. It simply treats a video stream as a series of still photos, compressing each individually, with no interframe compression. Because it uses no interframe compression, it is ideal for editing.

What is MCMP?

MCMP, or Motion CMP, is a video adaptation of LEAD's proprietary CMP compression code. MCMP delivers smaller file sizes and can maintain better image quality than MJPEG with the same or better image quality.

What do Encoder and Decoder mean?

A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

This product includes part of the following features:

Image Compression

Files and File Formats

For more details on this product, refer to:

www.leadtools.com/SDK/Multimedia/Multimedia-MCMP-MJPEG-codec.htm

This product is included with:

LEADTOOLS Medical Multimedia Module

This product may be added to:

LEADTOOLS Multimedia

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trademark or a registered trademark of Microsoft Corporation.

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD AAC Audio Codec

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD AAC Audio Codec

LEAD's AAC audio Codec is a multimedia compressor/decompressor optimized for speech coding that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing audio software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit AAC audio streams.

Advanced Audio Coding (AAC), also known as MPEG-2 Part 7, is a digital audio encoding and lossy compression format. AAC delivers high quality audio at a lower bitrate compared to other audio encoding standards like MP3. It is commonly used in MPEG4 or H264 ISO MP4 files and is also the audio format that is currently used by the iPod and PSP. AAC also supports both constant and variable bit rates.

Key features of the LEAD AAC Audio Codec:

  • Supports both variable and constant bitrates.

  • Supports selection of output channels.

  • Supports surround sound.

  • Supports both versions of AAC, MPEG4 and MPEG2.

  • Supports different profiles: Low Complexity, Main and Long Term Prediction.

  • Supports 2 stream formats: Raw and ADTS.

  • Supports selection of output sample frequency.

  • Includes cutoff frequency option.

  • Includes a force stereo output option in the decoder Also known as a decompressor, this is a module or algorithm to decompress data. .

    • What do Encoder and Decoder mean?

    A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

    This product includes parts of the following features:

    Image Compression

    Files and File Formats

    For more details on this product, refer to:

    http://leadtools.com/SDK/Multimedia/Multimedia-AAC-codec.htm

    This product may be added to:

    LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD AC3 Audio Encoder

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD AC3 Audio Encoder

LEAD's AC3 audio Encoder is a multimedia compressor/decompressor optimized for speech coding that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. You can use the encoder with your existing converter or DVD creator application, as long as it allows you to select the audio encoder.

AC3 is the sound format for digital television (DTV), digital versatile discs (DVDs), high definition television (HDTV), and digital cable and satellite transmissions. AC3 is a 5.1 format, which means that it provides five full-bandwidth channels, front left, front right, center, surround left, and surround right. A low-frequency effect (LFE) channel is included for the sound needed for special effects and action sequences in movies. AC3 also has a downmixing feature that ensures compatibility with devices that do not support the 5.1 format. It also supports unchanged audio input, Force Mono, Force Stereo or Force 6 Channels. This audio encoder is needed in order to create DVDs that have 5.1-channel surround sound.

Key features of the LEAD AMR Audio Codec:

  • Create Dolby Digital tracks with 6-channel surround sound.

  • Create DVDs with Dolby surround.

  • Convert a 2-channel input into a 6-channel output or encode 6-channels as is.

    • What do Encoder and Decoder mean?

    A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

    This product includes parts of the following features:

    Image Compression

    Files and File Formats

    For more details on this product, refer to:

    http://www.leadtools.com/Help/LEADTOOLS/v17/Multimedia/Filters/Default.htm#Filters/LEADAC3Encoder.htm

    This product may be added to:

    LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD AMR Audio Codec

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEAD AMR Audio Codec

LEAD's AMR audio Codec is a multimedia compressor/decompressor optimized for speech coding that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing audio software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit AMR audio streams.

The AMR speech coder consists of the multi-rate speech coder, a source controlled rate scheme including a voice activity detector and a comfort noise generation system, and an error concealment mechanism to combat the effects of transmission errors and lost packets. The multi-rate speech coder is a single integrated speech codec with eight source rates from 4.75 kbps to 12.2 kbps, and a low rate background noise encoding mode. The speech coder is capable of switching its bit-rate every 20 ms speech frame upon command. These features make LEAD AMR the preferred audio compression for streaming and video conferencing.

Key features of the LEAD AMR Audio Codec:

  • User-definable bit rate.

  • Support for bitrate switching during conversion.

  • Optimized for video conferencing.

    • What do Encoder and Decoder mean?

    A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

    This product includes parts of the following features:

    Image Compression

    Files and File Formats

    For more details on this product, refer to:

    http://leadtools.com/SDK/Multimedia/Multimedia-AMR-codec.htm

    This product may be added to:

    LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


LEAD Vorbis Audio Codec

Available in LEADTOOLS Multimedia toolkits.

LEAD Vorbis Audio Codec

LEAD's Vorbis audio Codec is a multimedia compressor/decompressor optimized for speech coding that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing audio software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit Vorbis audio streams.

Vorbis is an audio compression commonly used to store digital music or any audio data. The compressed audio data can be stored inside AVI or Ogg files. Compared to MP3 compressed audio files, Vorbis based compression produces audio files that maintain a higher sound quality and/or a smaller compressed size, depending on the needs of the user. For example, the user has the option of keeping his or her digital music collection at the same sound quality level as MP3, but requiring significantly less disk space. Alternatively, a user can commit the same amount of storage (disk space) as the MP3 based files, however the digital music will have higher quality sound.

Key features of the LEAD Vorbis Audio Codec:

  • Supports both variable and constant bitrates.

  • Provides several predefined quality factors based on the desired quality:size ratio.

  • Ability to manually specify number of input channels.

    • What do Encoder and Decoder mean?

    A codec can consist of two components, an encoder and a decoder. The encoder performs the compression function and the decoder performs the decompression function.

    This product includes parts of the following features:

    Image Compression

    Files and File Formats

    For more details on this product, refer to:

    http://leadtools.com/SDK/Multimedia/Multimedia-Vorbis-codec.htm

    This product may be added to:

    LEADTOOLS Multimedia

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


Files and File Formats

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Files and File Formats

Supported File Formats

LEADTOOLS currently supports over 150 different image formats and sub formats. With thousands of customers in all areas of applications development, LEAD Technologies continues to expand support for new formats and new format sub-types in response to the ever changing demands of developers worldwide.

Supported file formats and variants include: ABC, JPEG XR / HDP, JPEG, JPEG 2000 (J2K, JP2, JPX), JBIG, DICOM, FlashPix (FPX), Fuji Exif 2.0 (EXF), PDF, Adobe PhotoShop (PSD), Kodak PhotoCD PCD, EPS, IOCA, MODCA, CALS raster (CAL), Windows Icon (ICO), Windows Cursor (CUR), PC Paintbrush (PCX), Multipage PCX (DCX), IMG, Windows DIB, FAX raw, Winfax (WFX), MAC, VDA, GIF (Embedded Text, Animated, Interlaced, Transparency), PNG, Targa (TGA), Sun Raster (RAS), Macintosh PICT (PCT), LEAD CMP, Windows BMP, OS/2 BMP, Microsoft FAX (AWD), Windows Metafile (WMF), Enhanced Metafile (EMF), WordPerfect (WPG), AVI, MPEG2, ISO, OGG, WMV, Microsoft Paint (MSP), TIFF 6.0 (MPT, JPEG, Packbits, Huffman, RLE, LZW, CMYK, CCITT, CCITT G31D, CCITT G32D, CCITT G4, Bitonal, Grayscale, Palletized, RGB, YCbCr, CIELAB), NITF, TDB, and XPS.

General File Format Support

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few.

LEAD Technologies is constantly adding support for new file formats, and "flavor" support to formats already supported. The extensive format support provided by LEADTOOLS will give your application the flexibility to support almost any image you encounter.

Visit LEAD’s website at http://www.leadtools.com/sdk/formats/image-formats.htm for a complete list of LEADTOOLS’ file format support.

Vector File Format Support

Support for vector file formats is provided by the LEADTOOLS Vector Imaging Pro toolkit. Supported file formats include Vector File Formats include CGM, DGN, DRW, DWF, DWG, DXF, EMF, WMF, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX, NAP and SHP. LEADTOOLS Vector Imaging provides 2-D and 3-D vector imaging for loading, viewing, modifying and saving vector files to memory/disk in native vector format. Objects are represented as exact geometrical entities, rather than approximated by a collection of discrete pixels, making them inherently scalable and suitable for other mathematical transformations. Drawing and CAD/CAM programs typically use vector images.

For more information on the support provided by the LEADTOOLS Vector Imaging Pro toolkit, refer to:

Vector Imaging

MRC File Format Support

The LEADTOOLS MRC (Mixed Raster Content) file format results in both high compression factors and high detail retention. This format enhances LEADTOOLS file input/output functionality by adding support for raster color documents containing mixed image and text components. The MRC file format breaks an image into three different layers: foreground, background, and mask. Each layer is compressed separately using the best type of compression for that data type and is later uncompressed and recombined to restore the original image. Because standard compression schemes are geared towards an image being entirely text or color, the MRC model offers the advantage of using optimal compression for images that have both text and color in the same image.

The foreground layer contains color data for the text and line art, and may also contain photographic or continuous tone color data. The background layer generally contains low-resolution color image data, such as a background image, a wash or other pattern that would have text overlaid on it. The mask layer or the selector layer controls the process of image regeneration contains binary image data that is high spatial resolution, such as text and line art. This layer is used for drawing the corresponding foreground and background layers.

Segmentation can be performed automatically with the option to optimize it manually or it can be done only manually. Compression can be specified for each area type. The compression for 1-bit black and white areas can be CCITT G3 1D, CCITT G4 2D, CCITT G4 or JBIG. The compression for color areas is JPEG.

The LEADTOOLS MRC File Format support is available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

PDF File Format Support

Support for the Portable Document Format, (PDF) is provided by the LEADTOOLS PDF Plug-in, which can be added to any toolkit to extend support for PDF, PDF/A, Postscript, and EPS formats.

For more information, refer to:

LEADTOOLS PDF Plug-ins

Multimedia File Format Support

Non-Multimedia toolkits can load AVI as raster still images and can save AVI files.

In the LEADTOOLS Multimedia toolkits, LEAD provides much more extensive support for multimedia formats. LEADTOOLS Multimedia products can playback any input file format supported by DirectShow, including:

  • AVI

  • Adobe HD

  • AVCHD

  • DVD

  • MPEG-2 (Transport and Program)

  • MPEG1 Video

  • MPEG1 Layer-3 Audio (MP3)

  • ISO (MP4, 3GPP, AAC, AVC1, MOV, Quicktime 2.0)

  • DivX

  • WMV Windows Media Format

  • WMA Windows Media Format

  • WAV

  • DVSD

  • OGG

  • Still image formats including TIFF, JPEG, BMP, PSP thumbnail, etc.

  • DICOM (requires LEADTOOLS Medical Multimedia Module, LEADTOOLS Medical Imaging, LEADTOOLS Medical Imaging Suite, or LEADTOOLS PACS Imaging)

LEADTOOLS Multimedia products can convert any of the supported playback file formats to:

  • AVI (using any available video compressor on the computer)

  • Adobe HD

  • AVCHD

  • DVD

  • MPEG-2 (Transport and Program)

  • MPEG1 Video

  • MPEG1 Layer-3 Audio (MP3)

  • ISO (MP4, 3GPP, AAC, AVC1, MOV, Quicktime 2.0)

  • DivX/ XVID

  • AC3

  • WMV Windows Media Format

  • WMA Windows Media Format

  • WAV (using any available audio compressors on the computer)

  • DVSD

  • MPEG-2 DICOM

  • OGG

  • Still image formats including TIFF, JPEG, BMP, PSP, thumbnail etc.

  • DICOM (requires LEADTOOLS Medical Multimedia Module, LEADTOOLS Medical Imaging, LEADTOOLS Medical Imaging Suite, or LEADTOOLS PACS Imaging)

For more information on the support provided by the LEADTOOLS Multimedia toolkits, refer to:

LEADTOOLS Multimedia

Working with Files

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few. LEADTOOLS offers extensive libraries of functions that allow you to deal with each type of image format and its special options, whether its Comments, Getting and Setting File Information, Layers, Loading Files, Multipage Files, Saving Files, or Tags. Each of these unique options is described in more detail in the following sections.

Comments

Some file formats can contain comments, and some cannot, and each file format has its own set of comment types. LEADTOOLS supports each of the following types of comments in one or more products:

  • DICOM File Comments

  • Exif File Comments

  • FlashPix File Comments

  • GIF File Comments

  • IPTC Comments

  • JPEG and LEAD File Comments

  • JPX Boxes

  • PNG File Comments

  • TIFF File Comments

Getting and Setting File Information

LEADTOOLS provides extensive functionality for getting file information. Whether an image file is on disk or in memory, you can get information about the image before loading it. You can also handle file-format-specific information, such as the page number or physical resolution. Support includes functions that allow you to:

  • Obtain descriptive information about a file (including those loaded in memory).

  • Obtain embedded audio data.

  • Determine what resolutions a file contains.

  • Load a stamp.

  • Read or load extensions from an Exif file.

  • Read the transforms stored with an image in a FlashPix file.

  • Detect image format / compression.

  • Detect view perspective, color order, color space and bit-depth.

Functionality for setting file information is just as extensive. Support includes functions that allow you to:

  • Specify a callback function for handling input data that is in an undetermined format, used for loading raw FAX data (CCITT Group 3 or Group 4), raw run-length-encoded data (4-bit or 8-bit), raw Bitfield compressed data, raw PackBits compressed data or raw uncompressed data.

  • Specify the physical resolution (width and height) of the FlashPix, PhotoCD, or JBIG file to load.

  • Set the resolution to be used for loading or converting a PhotoCD file.

  • Set the resolution for the next save operation. Currently, this function only works with the JBIG format.

  • Set the DPI (dots per inch) value that LEADTOOLS uses when loading WMF files. By default, the value is 0. WMF files can contain vectored graphics or raster images. LEADTOOLS can load either type, but can save only raster images. The issue of image resolution arises mainly when loading vectored graphics.

  • Write comments.

  • Write transforms to a FlashPix file.

Layers

PSD file formats support layers. LEADTOOLS provides functionality to allow the loading of an individual layer. PSD files can also be saved with layer information.

Loading Files

LEADTOOLS provides many options when loading image files. You can load an image at its own color resolution, manipulate it, and display it, regardless of current video mode. You can also convert the image to a specific color resolution (bits per pixel) as you load or save it. You can supply the input for a load operation or the output of a save operation, and you can add processing, such as a paint-while-load feature. You can control the execution of a load procedure as you supply transmitted image data. You can also load an image from a file, into a bitmap, and resize the bitmap as it loads.

The LEAD and JPEG (JFIF) file formats can be extended to support progressive loading and saving of images. Progressive loading is useful for transmitting images, because the first part of the file contains the full dimensions of the image. If you want to take advantage of this feature when loading a progressive file, you can control the number of passes that are required to complete the image.

JBIG and JPEG2000 also support progressive loading of an image.

Multipage Files

LEADTOOLS supports multipage file formats and formats that emulate multi-page files. These include:

  • Animated Cursor

  • Animated Gif

  • CALS3

  • DCX

  • DICOM

  • FlashPix

  • FLC

  • GIF

  • IFF

  • IOCA/MODCA

  • PCX

  • PDF

  • TIFF (MPT)

When working with multipage files, you can delete individual pages within the file. When loading a multipage file, you can load all pages, or use a different function to load only one of the pages.

To load and play an animated GIF file, you can load a list of bitmaps from the file, and then play the list to a target bitmap in a loop that displays each change in the target bitmap. You can also create an animation sequence from scratch and save the bitmaps to create an animated GIF file.

Saving Files

LEADTOOLS provides many options when saving image files. You can convert an image to a specific color resolution (bits per pixel) as you save it. You can save a bitmap to a file in a memory buffer.

The LEAD and JPEG (JFIF) file formats can be extended to support progressive loading and saving of images. Progressive loading is useful for transmitting images, because the first part of the file contains the full dimensions of the image. If you want to save a progressive file, you can control the number of passes that are required to complete the image.

Tags

The TIFF file formats support a number of comments that are saved and loaded using predefined tags. LEADTOOLS provides functionality to specify a comment to be saved as well as read and write comments. If the comments do not meet your needs, you can define your own tag for saving additional non-raster data in a TIFF file. The LEADTOOLS functions let you save one additional tag in a TIFF file. They are designed for future expansion to more than one tag.

See Also

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Multimedia


Image Display

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Image Display

LEAD Technologies continually reviews and adds file format support to give your application control over the display of almost any Raster or Vector image you encounter. LEADTOOLS currently supports over 150 different image formats and sub formats, each of which has its own unique set of load/save/display options. These may encompass varying types and/or degrees of compression, such as a range of image information bit-depths, progressive (multi-pass) image display, and the ability to maintain multi-page or multi-channel images, animations, or non-image data.

Raster Image Display

LEADTOOLS provides numerous functions to let you take control of your application's image display. Control brightness and contrast settings, color reduction with dithering and palette control, scaling/fitting, enlargement/reduction, panning, scrolling, and painting with transparency and/or regions.

Further, LEADTOOLS provides image-list and thumbnail browser controls, a special magnifying-glass feature, an automated pan-window control, a viewing control designed especially for working with animated GIF'S, easy display of images with alpha transparency, and a Zoom View control that allows you to annotate pre-defined zoomed regions.

Key Features:

Intensity, contrast and gamma correction. LEADTOOLS renders an image of any color depth (1 to 64 bit) to any display device, automatically handling any color reduction or expansion. Changes can be applied to the display without affecting the original data. If desired, color reduction and display settings can be rendered into the image. (See Image Processing.) You can even render images with a color or region of interest specified as transparent.

Dithering. Images can be automatically dithered to match the output display device on the fly, without changing the image in memory. Specify the dithering method for images that have more bits per pixel than the current video mode, using Normal dithering (error diffusion), Ordered dithering (faster, but less accurate than normal), No dithering, which relies on the display device for color reduction.

Position and Scale. Position the displayed image, and zoom in or out (enlarge or reduce the display) by scaling and clipping. Use nearest neighbor (fastest), bilinear (fast-good quality) or bicubic (best quality) resampling for enlarged/reduced display size.

Specify a source rectangle (portion of source image to paint) and destination rectangle (position on screen or drawing surface on which to paint it) for complete control over image zoom and position. Or, specify higher level properties like ZoomFactor (fit-to-window preserving aspect ratio, stretch to entire window, fit-to-width, 1:1 normal display).

Automated Controls. When working with the ActiveX, COM, or .NET controls, you can set properties which determine the way that images are displayed in the control, such as AutoScroll (automated scroll bars), AutoSize (snap control to image), PaintSizeMode (1:1 scale, fit image to control, zoomed at specified magnification factors).

When used with the AutoScroll option, all Scroll Bar activity is automatic (scroll bars respond to programmatic changes of display settings, and display settings are updated by user's use of scroll bars).

Palette Control. If the display mode is 256 colors or less, you can use a palette already associated with the image, or use a fixed palette to eliminate palette (color) shifting when displaying more than one image at a time.

Image List and Thumbnail Browser Controls. Display and manipulate a list of images as an array of thumbnails using the ImageList Control, or use the Thumbnail Browser for browsing entire directories of image files.

Pan Window. The automated pan window enables navigation through a large image using a small thumbnail view.

Regions of Interest. Display an automated rubber band (rectangle, ellipse or freehand) to mark an area and create a region of interest.

  • Define the client area of a LEAD control as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text. (You can also get a display surface derived from the actual image stored in memory in order to use Windows GDI to draw permanently into the image - see Image Processing.

  • Paint an image only in a selected region of interest, or paint an image with transparency (any pixels which are the selected transparent color are not painted).

  • Zoom in on a selected area. Use with automated rubber banding for entirely automated behavior, or specify selected area in code.

  • Perform any image processing command on only a predefined region of an image.

Apply Effects. Apply any of over 2000 Special Effects, such as wipes, fades, dissolves, transitions commonly used in slide presentations.

Complete Control. When painting images on any video device, you can:

  • Selectively force repainting of the image in a LEAD control to avoid unnecessary repaints, or use AutoRepainting to automate all display updates.

  • Limit the area to be painted by specifying the source and destination clipping areas (independent of source and destination rectangles which position image on screen).

  • Use Double Buffer painting to eliminate flicker when painting.

  • Use a buffer as the source to paint. (Can be used, for example, to paint an image as it is being loaded)

  • Specify an option for fast painting (without device error checking).

  • Apply ROP codes, which determine how to interact with the existing image on the screen (not supported in .NET).

Display Enhancement. Using toolkits from our Document and Medical product line, you can

  • Specify a favor-black option which prevents loss of details, such as fine lines, when a 1-bit (black-and-white) image is scaled down (zoomed out).

  • Specify a scale-to-gray option, which increases the clarity of 1-bit (black-and-white)images when they are scaled (zoomed out).

  • The rotated display feature allows rendering images rotated in 90-degree increments without changing the image in memory. Large 1-bit images can remain compressed in memory while decompressing only the portion needed for display.

Zoom View. Toolkits from our Document and Medical product line include a Zoom View control that allows you to display and/or annotate multiple pre-defined zoomed regions.

LEADTOOLS Raster Image Display features are available in the following products:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Vector Image Display

The LEADTOOLS Vector Image Display features provide support for 2D and 3D Vector formats. Support for primitive objects include Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping objects. Vector images can also be rotated, scaled and translated as a whole (not individual objects) for display purposes. In addition there are low and high-level functions to control the view of vector drawings include zooming (both uniform or around any axis), panning, rotation (around any axis) and anti-aliasing. Vector drawings can be scaled to any resolution desired without distorting the original image, ensuring that fine details of the drawing will not be lost during printing.

The LEADTOOLS Vector Image Display features are available in the following products:

LEADTOOLS Vector Imaging Pro


Printing

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Printing

The LEADTOOLS products support three categories of printing: basic printing, available in all toolkits; printing through the LEADTOOLS Virtual Printer Driver, available only in the LEADTOOLS Virtual Printer Module and LEADTOOLS Document Imaging Suite; and vector printing, available in the Vector Imaging Pro toolkit. These categories are described in further detail in the following sections.

Basic Printing

LEADTOOLS can perform all image processing necessary to print directly to any Windows supported printer. You have complete control over the position of the image and the size of the printed image.

LEADTOOLS can preprocess the image for you so it matches the output device, you can manually preprocess the data before printing, or you can send the data as is so the printer driver processes the data. Some preprocessing functions include to ability to halftone an image (using any angle you specify for the halftone screen) to prepare images for back and white printing. Additionally, you can reduce the colors in an image to use an optimized palette, LEAD palette or a user defined palette.

With LEADTOOLS, you can easily print text using Windows GDI and print multiple images on the same page. Additionally, you can save coding time because the same code used to display an image can be used when printing. The .NET interface extends printing by offering a high-level class specifically designed to simplify printing.

The LEADTOOLS Basic Printing features are available in the following products:

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS Virtual Printer

With the LEADTOOLS Virtual Printer Driver you can:

Capture print jobs from any Windows application as EMF.

Programmatically install and un-install virtual printers to a target system.

Control access to the printer by locking it for use only by your application.

Configure the virtual printer to start your application when a print job is received.

Using the LEADTOOLS Document Writers, you can export the captured print job as any of the supported document formats.

Using LEADTOOLS, you can export the captured print job as any of the supported raster image formats.

The LEADTOOLS installation program installs a sample LEADTOOLS Virtual Printer for you. When you print to this printer from any Windows application, the example program will execute and you can then save the print job as a document file or raster image file.

The LEADTOOLS Virtual Printer is available in the following products:

LEADTOOLS Virtual Printer Module

LEADTOOLS Document Imaging Suite

Vector Printing

LEADTOOLS support for Vector printing features functionality to scale the vector drawing to any resolution desired without distorting the original image ensures that fine details of the drawing will not be lost during printing.

The LEADTOOLS Vector Printing features are available in the following products:

LEADTOOLS Vector Imaging Pro


LEADTOOLS WPF Standard .NET

The Microsoft Windows Presentation Foundation environment provides a consistent programming model for building applications. Directly related to XAML, it provides a clear separation between business logic and the user interface, enabling you to build applications that blend the user interface, documents, images, and other content for delivery on the desktop or across-the-web.

Business logic models developed by business analysts, marketing departments, or end users (using XAML plug-ins) can be used natively as application front-ends. This eliminates the need for coding (or re-coding) from "storyboards," instead allowing for direct collaboration among web developers, art departments, business analysts, and back-end programmers.

WPF is pre-installed in Windows Vista, and is also available for installation on Windows XP SP2 and Windows Server 2003.

WPF supports robust imaging capabilities, interface automation, data-driven user interfaces and visualization, as well as Windows shell integration. WPF can natively access Windows Imaging Component (WIC) codecs and APIs, allowing developers to write image codecs for their specific image file formats.

The LEADTOOLS WPF Standard Edition includes controls for everything you need to start adding imaging functions to your Windows Presentation Foundation (WPF) applications.

Key Features:

  • WPF BitmapSource Viewer - Supports all Microsoft .NET BitmapSource image objects. Includes Display, Scroll, Zoom, Margin, Frame, Shadow, PanWindow, and customizable MagGlass options. Provides interactive UI Tools like ZoomTo, Pan, CenterAt, and Scale.

  • ImageList Control - Lets you display lists of thumbnail images in multiple View Styles like Explorer, Normal, Button, and User-defined. Allows you to set Image List Item Size, Selection Style, and scroll style.

  • WPF Bitmap Effects. Use 130+ image processing effects and functions to add visual interest to WPF content.

  • Windows Imaging Component (WIC) Codecs. Instantly add support for 40+ file formats to any WIC/WPF application, including the Windows XP SP3 Explorer and Vista Photo Explorer.

This product is included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS ActiveX (OCX)

LEADTOOLS ActiveX (OCX) Main Control Module provides custom controls developed by LEAD Technologies, Inc. for incorporating image compression, file format support, and image processing into your applications.

You can use the LEADTOOLS ActiveX in any programming environment that supports OLE custom controls, including the following:

  • Visual C++ 1.5 and later (32-bit)

  • Visual Basic 4.0 and later (32-bit)

  • Access 95, version 7.0, and Access 97 (32-bit)

  • Visual FoxPro 3.0 and later (32-bit)

  • Delphi 2.0 and later (32-bit)

This product is included with:

LEADTOOLS Imaging


LEADTOOLS Win32 COM

Available in the LEADTOOLS Imaging toolkit.

LEADTOOLS Win32 COM

LEADTOOLS Win32 COM includes custom objects developed by LEAD Technologies, Inc. It supports UNICODE.

LEAD RasterDlg Object provides objects for incorporating into your applications reusable imaging common dialogs for the most common LEADTOOLS imaging functions and effects. These dialogs provided a quick and easy way to get and utilize user input necessary for image processing.

LEAD RasterTwain Object provides an object for incorporating TWAIN scanner control into your applications. This object provides all the functionality needed to create robust applications that can:

  • manage TWAIN sources.

  • acquire pages from a specified source.

  • handle different TWAIN sources, like scanners, barcode readers, and digital cameras.

You can use LEADTOOLS Win32 COM in any programming environment that supports COM Objects, including the following:

  • Visual C++ 5.0 and later

  • Visual Basic 5.0 and later

  • Delphi 6 and later

This product is included with:

LEADTOOLS Imaging


Database Imaging

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Database Imaging

LEADTOOLS has specific features designed for the imaging database developer. .NET data binding allows you to use the .NET database engine to store and retrieve image data to/from any database supported by .NET. Load/Save memory (stream) and Load/Save file offset functions provide low-level methods for working with databases.

You can use the database features to store images in any of the file formats supported by LEADTOOLS. LEADTOOLS' database support includes a wide variety of callback routines and features multipage support. These features, when combined with the excellent compression options available in LEADTOOLS, provide a solid base for building robust database applications such as those used in fields like Real Estate, Law Enforcement and Internet on-line shopping.

You can maintain images in a database, using any valid file format to store an image in a long binary field.

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Imaging Common Dialogs

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Imaging Common Dialogs

The LEADTOOLS Common Dialog boxes greatly simplify development and save hours of tedious programming by combining Windows Common Dialog functionality with LEADTOOLS imaging functionality to provide imaging-specific capabilities. The Common Dialog boxes provide complete code for all common imaging dialogs such as FileOpen, FileSave, Color Resolution, Image Processing/Filtering, and Effects. Thumbnail previewing of image changes saves processing time and avoids un-dos. You can specify your own String and/or Text, as well as handle Language Customization – simplifying the task of localizing your software for International users.

The LEADTOOLS Imaging Common Dialogs also provide input dialog boxes for all LEADTOOLS image processing functions. These dialogs allow you to quickly and easily enable your application to gather input from end-users for the parameters required by the various LEADTOOLS functions. These dialogs can also be used to automatically process the image based on end-user input (thus reducing the amount of code you have to write).

The dialog functions feature:

  • Reusable dialogs for the most common LEADTOOLS image processing functions and effects.

  • Extended FileOpen and FileSave dialogs which contain LEADTOOLS specific options.

  • Thumbnail Preview option for FileOpen dialog to allow the user to preview images without loading them.

  • Thumbnail Preview for image processing dialogs to allow the user to preview changes without affecting the original image.

  • A Help Button callback function to let you provide custom help information for each dialog (if desired).

  • User Interface control for the dialogs provided through flags passed to each dialog function or method.

  • Optional Automatic processing of the image by the dialog.

Toolkits within the LEADTOOLS Document and Medical Imaging product line offer additional dialogs.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Color and Color Space Conversion

Available in LEADTOOLS Imaging, Imaging Pro, Document, and Medical Imaging toolkits.

Color and Color Space Conversion

Color resolution and color space options give you the flexibility to make your images look just right for your application, whether you are working with medical images, scanned documents or digital photographs.

Color Resolution Control

LEADTOOLS can convert images to and from any other color resolution (1-bit to 64-bit), with multiple dithering methods and palette options. In the Medical toolkit, when working with 12- and 16-bit grayscale images, LEADTOOLS' window leveling allows you to select the desired range of bits to be used for display or processing.

  • Dithering methods include: Floyd Stein, Burkes, Ordered dithering, Color reduction, Stucki, Stephens, Sierra, and Jarvis.

  • Flexible palette options include LEAD's fixed palette, an auto-optimized palette, or a user defined palette.

  • LEADTOOLS can create a palette that is optimized for the particular image. Optionally, this palette can include the system identity palette.

  • Specify a fixed palette that is the same for all images that use it. The palette can be LEAD's fixed palette or the Netscape fixed palette.

  • Specify a palette of any size that you have created. In creating your own palette, you can let LEADTOOLS do part of the work. For example, you can fill in part of the palette, and let LEADTOOLS fill the rest with optimized colors.

  • Modify the colors in the bitmap palette.

  • Copy a palette from a device context.

  • Use a table to increase the efficiency of the palette that you define.

  • Use window leveling to map grayscale intensities by specifying the bit range and/or a user defined color map (requires Medical or PACS SDK).

Color Space Conversion

Images can also be converted, separated to, and reconstructed from RGB, CMYK, CMY, HSV, HSL, YUV, YIQ, CIELAB, XYZ, YCCK, Y41P, UYVY, YUY2, YVU9 and YCC color spaces. This can be done using LEAD's built in conversion functions, ICC color profiles, or emulation tables.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Enterprise

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Image Compression

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Image Compression

LEADTOOLS offers more compression options than any other toolkit on the market. LEADTOOLS supports industry standard compression algorithms such as JBIG, JBIG2, ABIC JPEG XR, JPEG, JPEG 2000, CCITT G3/G4, Huffman, Arithmetic, RLE, LZW and ZIPLIB, as well as LEAD’s own proprietary CMP, CMW (wavelet) and ABC (bitonal) compression. In the LEADTOOLS Document/Medical versions, you will find the fastest software only JPEG algorithms available, as well as support for MRC for achieving the smallest file size possible. With the compression options available in LEADTOOLS, your application will execute faster, images will use less storage space, and your transfer costs will be reduced. With LEAD's CMP, CMW (wavelet) and ABC (bitonal) compression, you will get even smaller file sizes while maintaining better image quality than the industry standard compression formats allow.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Image Processing

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Image Processing

LEADTOOLS has over 200 image processing functions, some of which are typically found only in high performance end-user programs such as PhotoShop. The image processing functions are separated into four categories:

Transforms: LEADTOOLS transforms include resize, resample (interpolated resize), rotate (.01 degree), flip, invert, reverse, crop, underlay, shear, transpose, fill, auto deskew and combine bitmap (using your choice of mathematical and Boolean operations).

Filters: LEADTOOLS color filters include sharpen, blur, intensity, contrast, gamma correct, invert, hue and saturation, histogram equalize, emboss, mosaic, posterize, median, average, oilify, edge enhance, solarize, despeckle, and add noise. LEADTOOLS spatial filters (which can be pre-defined or user-defined) include gradient, laplacian, sobel, prewitt, shift and difference, line segment. LEADTOOLS binary filters include erosion, dilation, max and min.

Drawing: With the LEAD DeviceContext, LEADTOOLS gives you access to the bitmap surface, on which you can draw or paint using Microsoft Windows GDI functions (such as TextOut, BitBlt, Ellipse, and Rectangle). Alternatively, the .NET interface allows you to create a GDI+ Graphics object from a LEAD bitmap for drawing.

Region of Interest: The LEADTOOLS region of interest makes it possible for you to process or paint only a specific portion of an image rather than the entire image. Regions can be comprised of any combination of rectangles, ellipses, rounded-rectangles, freehand shapes, polygons, transparent color and more.

Most of the LEADTOOLS functions that change the appearance of an image act on the bitmap (not just the display). This is an important distinction, because the changes become permanent when the bitmap is saved to a file.

To change the appearance of the image in a bitmap, you can do the following:

  • Define the bitmap as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text.

  • Automatically trim a bitmap to remove blank space around the edges.

  • Rotate the image. (Angles can be precise to 100th of a degree.)

  • Shear the image in the fashion of a parallelogram. (Angles are precise to 100th of a degree.)

  • Change the orientation by flipping the image horizontally or vertically.

  • With our Document and Medical toolkits, you can:

    • Automatically straighten (deskew) a 1-bit image.

    • Remove specks (despeckle) a 1-bit image.

    • Do fast rotation in 90-degree increments.

Adjust colors and intensities as follows:

  • Change brightness using a flat scale.

  • Change brightness using gamma correction.

  • Change contrast.

  • Stretch the range of intensities.

  • Remap intensities using a lookup table.

  • Invert colors.

  • Change hue and saturation.

  • Histogram equalize.

  • Fill with a specified color.

  • Get and put colors of individual pixels.

  • Apply the following kinds of conversions:

    • Halftone for display or printing.

    • Sharpen or blur.

    • Posterize, specifying the number of color planes.

    • Mosaic, specifying the tile size.

    • Emboss, specifying the lighting direction.

    • Soften an image using an average filter.

    • Reduce noise using a median filter.

    • Add noise in any or all color planes.

    • Apply an oil-painting effect.

    • Apply a solarization effect.

Apply filters to do the following:

  • Detect ranges of intensity.

  • Detect edges using gradient or Laplacian edge detection.

  • Detect lines using Sobel, Prewitt, shift and difference, or line segment detection.

  • Implement your own spatial filters.

  • Combine images using boolean and arithmetic operators, and color masking. (This is useful for combining filtered images with originals.)

  • Combine two images so that one appears to be an underlying texture of the other.

  • Combine multiple images to create a new image that resembles the current image.

  • With our Document and Medical toolkits, you can:

    • Apply morphological (binary) filters to erode or dilate black objects.

Use low-level functions to change parts of an image as follows:

  • Get and put rows of image data.

  • Get and put parts of rows.

  • Get and put the colors of individual pixels.

  • Process a region within a bitmap

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Image Processing: Region of Interest

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Image Processing: Region of Interest

LEADTOOLS region of interest makes it possible for you to process or display only a specific portion of an image rather than the entire image.

Regions can be defined as any combination of shapes including rectangles, ellipses, rounded-rectangles, freehand shapes, polygons, curves and Bezier curves, and more.

LEADTOOLS also lets you select regions based on the color of pixels within the image. You can select all pixels in an image having a specific color, or you can select contiguous regions starting with a seed pixel and a color-match threshold by using the "Magic Wand". Complex regions can be built using a variety of boolean operations on simpler regions, including union, intersection, xor, and inverse.

Additionally, LEADTOOLS includes region functionality not found or is difficult in Windows including resizing, rotating and other transformations of regions.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Special Effects: Display & Drawing

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Special Effects: Display & Drawing

LEADTOOLS provides special effects for developing multimedia projects or presentation applications. You can use many paint effects, dissolves, and transitions. Effect options allow you to choose from over 2000 paint effects, 36 gradients, 80 shapes, 12 3-D text styles, 64 dissolves and 43 transition effects with delays, grain sizes, pattern brushes and a colored wand, all with control over the speed and granularity of each effect. You can also draw plain or three-dimensional text and graphic shapes on the screen or on the bitmap.

With the LEADTOOLS special effects you can develop visually stimulating multimedia projects, presentation applications, or enhance websites.

Specifically, you can do the following:

  • Specify an effect that is applied when painting the image from a bitmap.

  • Specify a transition between images, which is an effect that paints a pattern or gradient color (instead of the image from a bitmap).

  • Control the speed, granularity, multiple paint passes, transparent color, and wand usage when painting images or transitions.

  • Specify a transparent color and paint a control with a transparent background.

When drawing shapes or text objects on the screen or on the bitmap, you can do the following:

  • Paint a rectangular area that contains a pattern or gradient color. This is useful for creating a bitmap that can be used as the background of a shape object or the foreground of a text object.

  • Draw a shape with a three-dimensional appearance. The shape can be one of 80 variations of rectangles, triangles, circles, and so forth, or it can be created from an existing Windows region.

  • Draw a text object with a three-dimensional appearance. The text can be rotated with precision to a tenth of a degree.

  • Specify a bitmap to use as the background of a shape, or as the foreground of a text object.

  • Draw a frame with a three-dimensional appearance. (In the ActiveX the frame is applied as a border of the control.)

  • Draw a simple Windows-style line, rectangle, or ellipse, with standard options for the draw-mode, pen, and fill.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


DigitalPaint

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

DigitalPaint

LEADTOOLS DigitalPaint features let you incorporate Paint capabilities into your Windows applications by providing the functions necessary to write a painting program or any painting related application. The painting output can be painted to the control, a bitmap, or both. In addition, LEADTOOLS DigitalPaint provides the option of color restriction, using an optional restriction palette.

The painting tools are divided into five groups, as follows:

  • Paintbrush group.

  • Shape group.

  • Region group.

  • Fill group.

  • Text group.

Each group is described in further detail in the following sections.

Paintbrush group

The LEADTOOLS DigitalPaint paintbrush group has most of the features found in any artistic painting program. The created paintbrush is translated and scaled automatically for the control and/or the bitmap, using user-defined transformation settings.

Shape group

The LEADTOOLS DigitalPaint shape group eliminates some of the Windows API programming normally required when drawing shapes. In addition, shapes may be painted with varying degrees of opacity, or with a paper texture, or with a gradient background, etc. The resulting shapes are translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

This group can draw the following shapes:

  • Line

  • Rectangle

  • Rounded rectangle

  • Ellipse

  • Polygon

  • Polybezier.

Region group

The LEADTOOLS DigitalPaint region group can create regions ranging from simple to very complex (many of which are not supported by Windows). Functionality also includes region scaling, which is not supported directly by Windows. Resulting regions are translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

Regions can be created by using shapes (Rectangles, Rounded rectangles, Ellipses or Polygons) or by using fills (Surface, Border, or Color Replacement).

Fill group

The LEADTOOLS DigitalPaint fill group gives the user complete area filling solutions with regards to both the method of filling and the features of filling. The resulting filled area is translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

There are three Fill group filling methods: Surface, Border and Color replace. The Surface fill method fills an area that contains a specified color starting at a specified point and continuing in all directions. A tolerance range can also be set to accept colors very close in value to the specified color. The Border fill method fills an area starting at a specified point and continuing in all directions until finding a specified color. A tolerance range can also be set to stop filling when colors very close in value to the specified color are found. The Color replace fill method replaces every pixel using the current fill settings.

Text group

The LEADTOOLS DigitalPaint text group includes comprehensive text drawing features. Drawn text is translated and scaled automatically for the device context (DC) and/or the bitmap, using user-defined transformation settings.

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Scanning / Screen Capturing

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Scanning / Screen Capturing

LEADTOOLS supports high speed scanning using both Windows Image Acquisition (WIA) and TWAIN (1.0 and 2.0) industry standards enabling image acquisition in document (halftone), grayscale or color modes.

TWAIN

LEADTOOLS' TWAIN support includes both native and buffered RAM transfer modes. Developers have the option of using the default TWAIN interface provided by the TWAIN datasource, or they can choose to by-pass the user interface to create their own, as long as the driver supports it. The LEADTOOLS TWAIN functions offer control over image size, position, brightness, contrast, resolution, and orientation. Support for single and multi-page acquire is provided. With LEADTOOLS, your application can acquire images from TWAIN compliant devices such as scanners, capture cards, and digital cameras from manufacturers such as Kodak, Hewlett Packard, Microtek, Logitech, Fuji and many more.

Fast TWAIN

With LEADTOOLS’ FAST TWAIN support (Document and Medical SDK's only), LEAD provides several functions to determine the best and fastest scan configuration available for scanning your images.

WIA

LEADTOOLS Windows Image Acquisition (WIA) provides a powerful set of functions spanning the full spectrum of digital imaging, including in-depth support for image acquisition from a wide variety of hardware devices.

Screen Capture

LEADTOOLS Screen Capture functions enable your applications to capture images that can be used with any of the LEADTOOLS image processing functions, and save them to any of the 150+ image file formats that LEAD supports. Capture options include capturing from the entire screen, a user defined rectangle, a specific window, the active window, the window under the cursor, and many more.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Windows Imaging Architecture (WIA)

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Windows Image Acquisition (WIA)

LEADTOOLS Windows Image Acquisition (WIA) provides a powerful set of functions spanning the full spectrum of digital imaging, including in-depth support for image acquisition from a wide variety of hardware devices.

Key Features:

LEADTOOLS WIA enables you to:

  • Control any scanner, digital camera or streaming video device that has a WIA driver. High-level acquisition support is provided for ease of use. Low-level functionality is also provided for flexibility and control in even the most demanding applications.

  • Acquire pages from a specified source.

  • Use the default user interface included with the WIA driver.

  • Determine the currently selected device type at runtime.

  • Enumerate all available WIA devices and enumerate all child items for certain specified parent item.

  • Create your own user interface to the driver interface whether your device were a scanner or a capture camera since LEADTOOLS WIA toolkit gives the ability to control the captured frames from the camera capture device you have and save the captured frames directly to your hard disk drive to the path you specify, also it gives you the ability to show the camera preview in any parent window you specify and controls the size of the preview inside that parent window.

  • Bypass the interface entirely for completely automated tasks or batch scanning.

  • Control the type of image acquired (black and white, halftone, grayscale, or color, as supported by the device).

  • Control the resolution (dpi), position, size, and orientation of the image to be acquired.

  • Use the Automated Document Feeder for single and multi-page scans, including support for duplex scanning.

  • Use selection dialogs to allow selection of WIA source, or select among multiple WIA sources in code.

  • Use memory or file transfer mode when acquiring from a WIA device.

  • Flexibly get and set the most common WIA 1.0 and 2.0 properties that the WIA device driver supports: either many properties at one time using a high level function, or individually get/set any supported WIA property using low level functions.

  • Use compression support whether in memory or file transfer mode. Scan data can be compressed using JPEG, JBIG, JPEG2K, PNG, RLE, GROUP 3 or GROUP 4 compression.

  • Supports both Win32 or the x64 platforms, using either the WIA 1.0 or the WIA 2.0 version of the toolkit.

  • Support multi-threading. For more information, refer to “Using Multiple Threads in a WIA Application” and “Communicating with a WIA Device in Multiple Threads or Applications” topics in the Microsoft Windows SDK Documentation.

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Peer-to-Peer Networking (P2P)

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Peer-to-Peer Networking (P2P)

LEADTOOLS provides a powerful set of P2P (peer-to-peer) networking functions that can be used for any application where you need to remotely manipulate large data sets. It is especially appropriate for efficiently managing large images and video streams.

P2P functions send commands and responses between local and remote computers. This enables use of a high-powered computer with massive storage capacity to store and process large numbers of images, while using a smaller, remote computer to send commands indicating which processes to perform and which images to use.

Using LEADTOOLS P2P functionality, your application can:

  • Transfer data, images and sound over the Internet, WAN or LAN.

  • Send peer-to-peer commands to process images.

  • Perform server-side image processing.

  • Create client/server applications, including video conferencing programs.

  • Create remote administration applications.

Example applications include:

  • Local Scan/ Remote Upload – Use LEADTOOLS TWAIN functionality in conjunction with this feature to scan pages on the client machine and easily upload them to a central server for processing and storage. This control allows you to send a bitmap in a single line of code.

  • Remote TV – Use the LEADTOOLS Multimedia SDK to capture and stream live TV content from a server machine to anywhere in the world. With the addition of this control, you can send commands from the client back to the server to manage the server (channel, audio device, video device, etc).

LEADTOOLS also includes classes and functions for higher level protocol support such as FTP and HTTP.

LEADTOOLS JPIP Module includes classes and functions to build JPIP clients and servers.

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Windows Presentation Foundation (WPF) Pro

Available in LEADTOOLS Imaging Pro, Document, and Medical Imaging toolkits.

Windows Presentation Foundation (WPF) Pro

(Contains .NET classes)

The Microsoft Windows Presentation Foundation environment introduced in Microsoft .NET 3.0 provides a consistent programming model for building applications. Directly related to XAML, it provides a clear separation between business logic and the user interface, enabling you to build applications that blend the user interface, documents, images, and other content for delivery on the desktop or across-the-web. That is, business logic models developed by business analysts, marketing departments, or end users (using XAML plug-ins) can be used natively as application front-ends. This eliminates the need for coding (or re-coding) from "storyboards," instead allowing for direct collaboration among web developers, art departments, business analysts, and back-end programmers.

WPF is pre-installed in Windows Vista, and is also available for installation on Windows XP SP2 and Windows Server 2003.

WPF supports robust imaging capabilities, interface automation, data-driven user interfaces and visualization, as well as Windows shell integration. WPF can natively access Windows Imaging Component (WIC) codecs and APIs, allowing developers to write image codecs for their specific image file formats.

LEADTOOLS WPF Pro takes full advantage of this capability, to provide you with out-of-the-box support for displaying, loading, saving, converting, processing, displaying, and annotating all image formats supported by the Microsoft Windows BitmapSource class in the WPF environment, as well as the 150+ formats supported by LEADTOOLS Raster Imaging toolkits.

Use LEADTOOLS WPF Pro to unleash the power of LEADTOOLS in your XAML applications. Using LEAD’s WPF interface, you can add LEADTOOLS OCR, TWAIN scanning, document pre-processing, medical imaging, and much more to any WPF application. Get Expression Blend-compatible and fully styleable controls for complete interoperation support between LEADTOOLS and Windows Presentation Foundation (WPF) images.

LEADTOOLS WPF Pro includes all the WPF functionality supported by LEADTOOLS WPF Standard .NET, plus:

Key Features:

  • Our most advanced WPF Image Viewer. Leadtools.Windows.Controls.Pro incudes image viewer controls that not only support all Microsoft .NET BitmapSource image objects, but works directly with LEADTOOLS Imaging Pro .NET classes, allowing you to leverage the full power of LEADTOOLS file format and image processing support. The fully styleable control includes scroll, zoom, pan, magnify glass, and image list.

  • Advanced WPF Image Processing. The Leadtools.Windows.Media namespace contains classes that let you convert a LEADTOOLS image (Leadtools.RasterImage) to and from a WPF image (System.Windows.Media.ImageSource). This namespace also gives you access to all LEADTOOLS image processing functions, allowing you to create powerful imaging applications using the WPF framework. Benefits include:

  • The most support for File Formats. Support even more file formats and flavors, as well as file metadata. Extend WPF file format support with LEAD’s WIC-enabled codecs to load and save many image formats including PDF, TIFF, lossless and lossy JPEG, JPEG2000, JBIG2, PSD, DICOM and many more. Includes low-level control when loading and/or saving image files.

  • Our most advanced Image Processing. Use over 130 Image Processing Effects including edge, blur, noise, artistic, texture, spatial, color adjustments and 3D. Low and High level image processing routines for document, medical, color adjustment, region processing, image analysis and statistics.

  • WPF Transition Effects. The Leadtools.Windows.Media.Transitions namespace allows you to add multiple slide show transition effects to your WPF projects. Choose from 10+ basic effects like wipe, blinds, push, rotate, and zoom, plus dozens of variants.

  • WPF Annotations. The Leadtools.Windows.Annotations namespace is unlocked with Document and Medical Imaging SDKs. It adds powerful annotation capabilities to documents and images in your WPF projects. These include not only lines, shapes, and pointers, but essential tools like redaction (blackout), hotspots, text, images, highlights, sticky notes, audio, images, stamps, rulers and hyperlinks.

With LEADTOOLS SDKs, developers can harness the robust power of LEADTOOLS extensive file format support and image processing features, while taking advantage of the newest UI development features provided by WPF. LEADTOOLS SDKs include WPF source code examples, making the integration of many years of LEADTOOLS imaging expertise into the latest Microsoft WPF technology a simple task.

These features include:

LEADTOOLS WPF Standard .NET (LEADTOOLS Imaging)

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


National Imagery Transmission Format (NITF) Support

Available in LEADTOOLS Imaging Pro, Document, and Medical Imaging toolkits.

National Imagery Transmission Format (NITF) Support

LEADTOOLS NITF provides functions that enable you to manipulate the NITF file format in your Windows applications.

The National Imagery Transmission Format Standard (NITFS) is the suite of standards for formatting and exchanging digital imagery and imagery-related products defined by the United States Department of Defense (US DOD). This standard allows for interoperability of systems used for formatting, transmitting, receiving, and processing imagery and imagery-related information, and describes the National Imagery Transmission Format (NITF) file format. For full background on the origination and purpose, and specifications of this standard, refer to the Department of Defence Interface Standard MIL-STD-2500B (this .pdf contains 119 pages so load times will depend on bandwidth; also requires that Adobe .pdf reader be installed) and the NITFS Technical Board Public Page.

The purpose of NITF is to transmit a file composed of an image accompanied by subimages, symbols, labels, text, and other information that relate to the image. One of the main features of the NITF is that it allows several items of each data type to be included in one file, yet any data types may be omitted. Examples of applications and capabilities that have been developed to exploit NITF standards include: remote platform video display, geo-registered image sectioning, image dissemination management systems, and interactive geospatial image annotation.

Key Features:

  • Creating and Parsing NITF Files

  • Appending Data to NITF Files

  • Getting and Setting Data Headers

These features are included with:

LEADTOOLS Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Advanced Bitonal Compression (ABC)

Available as an Add-On to LEADTOOLS Multimedia toolkits.

LEADTOOLS Advanced Bitonal Compression (ABC)

LEADTOOLS Advanced Bitonal Compression (ABC) reads and writes files with LEAD’s proprietary ABC compression. LEAD ABC compression is superior to JBIG2, LZW, TIFF Group 4 and other 1 bit compression.

These features are included with:

Read Support:

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Write Support

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Demos| Sample Programs | Unlocking Features | Install Directory | Redistributables | Documentation | Support | Licensing


FlashPix Support

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

FlashPix Support

LEADTOOLS provides increased versatility in the handling of color and grayscale images by taking advantage of the complete FlashPix file structure. The FlashPix file format is sponsored by Kodak, Microsoft, Hewlett-Packard, and many other industry leaders, who asked LEAD to add the format to LEADTOOLS and to join in supporting this image format technology. LEADTOOLS supports working with non-image data, loading and saving a portion of an image, working with thumbnail images in a FlashPix file, and working with transformation parameters in an existing FlashPix file.

These features are included with:

LEADTOOLS Imaging

LEADTOOLS Imaging Pro

LEADTOOLS Vector Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Data Matrix (Read/Write)

Available in LEADTOOLS Barcode Modules.

LEADTOOLS Data Matrix (Read/Write)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

Data Matrix is a two-dimensional matrix barcode consisting of black and white square modules arranged in either a square or rectangular pattern. The information to be encoded can be text or raw data. Typical data size is from a few bytes up to 2 kilobytes. The length of the encoded data depends on the symbol dimension that is used. Error correction codes are added to increase symbol strength: even if they are partially damaged, they can still be read. A Data Matrix symbol can store upto 2,335 alphanumeric characters.

Barcode 2D Data Matrix Key Features:

  • Contains Error Correction Code (ECC) to fix damaged barcode symbols.

  • Reads and writes color and gray symbols.

  • Store up to 2,218 ASCII characters in one barcode symbol.

  • Chain symbols to encode up to 33,225 characters.

  • Read barcodes independent of skew, orientation, flipping.

  • Very fast and accurate.

  • Read barcodes anywhere in the image or from region of interest, contained in any supported image file format (over 150 supported), acquired from scanner or digital camera.

  • Write to any supported raster format (over 150) into region of interest, print to any inkjet or laser Windows compliant printer.

  • Report back comprehensive information with 100% confidence for all detected barcodes such as the barcode sub-type, data string, X/Y position, bounding rectangle, etc.

  • Supports ECC200 error correction.

  • Many optional settings give you complete control over your barcode recognition process.

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

Sub-types supported:

Default Data Matrix Size | Data Matrix size 64x64
Data Matrix size 10x10 | Data Matrix size 72x72
Data Matrix size 12x12 | Data Matrix size 80x80
Data Matrix size 14x14 | Data Matrix size 88x88
Data Matrix size 16x16 | Data Matrix size 96x96
Data Matrix size 18x18 | Data Matrix size 104x104
Data Matrix size 20x20 | Data Matrix size 120x120
Data Matrix size 22x22 | Data Matrix size 132x132
Data Matrix size 24x24 | Data Matrix size 144x144
Data Matrix size 26x26 | Data Matrix size 8x18
Data Matrix size 32x32 | Data Matrix size 8x32
Data Matrix size 36x36 | Data Matrix size 12x26
Data Matrix size 40x40 | Data Matrix size 12x36
Data Matrix size 44x44 | Data Matrix size 16x36
Data Matrix size 48x48 | Data Matrix size 16x48
Data Matrix size 52x52 | Data Matrix Default Rectangular size

LEADTOOLS Data Matrix Barcode Support is included with:

LEADTOOLS 2D Barcode Module

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite


LEADTOOLS Barcode 2D PDF417 and MicroPDF417 (Read/Write)

Available in LEADTOOLS Barcode Modules.

LEADTOOLS Barcode 2D PDF417 and MicroPDF417 (Read/Write)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

PDF417 is the most common 2D barcode, and can be used in a variety of applications including Identification cards and inventory management systems. PDF417 offers more data storage than linear (1D) barcodes, up to 1,850 ASCII characters, and includes an Error Correction Code (ECC) which allows error-free reading even when a symbol has been partially lost or destroyed.

MicroPDF is usually used in conjunction with GS1 DataBar to create Composite Code B barcodes. The GS1 Composite Symbology is a group of two barcodes, one linear and one 2 dimensional. The linear barcode usually contains the primary data, while the 2D barcode contains related supplementary data such as expiration date, product weight, etc.

Barcode 2D PDF 417 (Read/Write) Key Features:

  • Store up to 1,815 ASCII characters in one barcode symbol.

  • Contains Error Correction Code (ECC) Level 0-8 to fix damaged barcode symbols.

  • Read barcodes independent of skew, orientation, flipping.

  • Read barcodes from region of interest, contained in any supported image file format (over 150 supported), acquired from scanner or digital camera.

  • Write to any supported raster format (over 150) into region of interest, print to any Windows-compliant printer.

  • Very fast and accurate.

  • Read / Write colored barcodes.

  • Support Truncated PDF417.

  • All Compaction Modes: Text, Byte, Numeric.

  • Many optional settings give you complete control over your barcode recognition process.

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

Barcode 2D MicroPDF 417 (Read/Write) Key Features:

  • Store up to 150 byte, 250 alphanumeric, or 366 numeric digits in one barcode symbol.

  • Full support to all available symbol sizes, together with Error Correction Code (ECC) Levels to fix damaged barcode symbols.

  • Read barcodes independent of skew, orientation, flipping.

  • Read barcodes anywhere in the image or from region of interest, contained in any supported image file format (over 150 supported), acquired from scanner or digital camera.

  • Write to any supported raster format (over 150) into region of interest, print to any inkjet or laser Windows compliant printer.

  • Very fast and accurate.

  • Read/Write colored barcodes.

  • All Compaction Modes: Text, Byte, Numeric.

  • Code 128 emulation codewords support to signal the decoder to transmit the symbol's data as if it were encoded in a Code128 symbol.

  • Many optional settings give you complete control over your barcode recognition process.

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

LEADTOOLS 2D Barcode PDF 417 Support is included with:

LEADTOOLS 2D Barcode Module

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite


LEADTOOLS Barcode QR Code (Read/Write)

Available in LEADTOOLS Barcode Modules.

LEADTOOLS Barcode QR Code (Read/Write)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, .NET, WCF, Windows Workflow, and COM Interoperability

Product Description:

QR Code barcodes are used for inventory management in a wide variety of industries. LEADTOOLS QR Code barcode can store up to 2,335 ASCII characters in one barcode symbol, and includes Error Correction Code (ECC) which allows error-free reading even when a symbol has been partially lost or destroyed.

Barcode QR Code Key Features:

  • Create QR Code barcode symbols from alpha/numerical text.

  • Includes Error Correction Code (ECC), which eliminates the possibility of corrupted read data.

  • Stores up to 2,335 ASCII characters in one barcode symbol.

  • Uses Error Correction Code (ECC) to fix damaged barcode symbols.

  • Reads barcode symbols independent of skew, orientation, flipping, and mirroring.

  • Very fast and accurate.

  • Output QR Code barcode symbols to any inkjet or laser Windows compliant printer.

  • Read barcodes anywhere in the image or from region of interest, contained in any supported image file format (over 150 supported), acquired from scanner or digital camera.

  • Reads and writes color, gray, and black/white symbols.

  • Report back comprehensive information with 100% confidence for all detected barcodes such as the barcode sub-type, data string, X/Y position, bounding rectangle, etc

  • Optional settings give you complete control over your barcode recognition process.

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

  • Advanced document cleanup functions to improve recognition of barcodes in images with real world problems.

Sub-types supported:

QR Default size | QR M2 18 | QR M2 37
QR M2 1 | QR M2 19 | QR M2 38
QR M2 2 | QR M2 20 | QR M2 39
QR M2 3 | QR M2 21 | QR M1 40
QR M2 4 | QR M2 22 | QR M1 1
QR M2 5 | QR M2 23 | QR M1 2
QR M2 6 | QR M2 24 | QR M1 3
QR M2 7 | QR M2 25 | QR M1 4
QR M2 8 | QR M2 26 | QR M1 5
QR M2 9 | QR M2 27 | QR M1 6
QR M2 10 | QR M2 28 | QR M1 7
QR M2 11 | QR M2 29 | QR M1 8
QR M2 12 | QR M2 30 | QR M1 9
QR M2 13 | QR M2 31 | QR M1 10
QR M2 14 | QR M2 32 | QR M1 11
QR M2 15 | QR M2 33 | QR M1 12
QR M2 16 | QR M2 34 | QR M1 13
QR M2 17 | QR M2 35 | QR M1 14
 | QR M2 36 | QR M1 DEF

LEADTOOLS QR Barcode Support is included with:

LEADTOOLS 2D Barcode Module

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite


Vector Imaging

Available in LEADTOOLS Vector Imaging toolkits.

Vector Imaging

LEADTOOLS provides 2-D and 3-D vector imaging for loading, viewing, modifying and saving vector files to memory/disk in native vector format. Formats include DXF (2D and 3D), EMF and WMF. 3D images can be rotated along the 3 standard axis, and painted using different illumination models. Drawings can be attached to a window for dynamic viewing. Viewing perspectives can be changed at runtime. Optimized drawing code can use OpenGL, DirectX or GDI functions. Includes 2D and 3D engine with camera, shades, lighting, resize, rotate, enumerate, select object and more. Vector images can be scaled from 1-1000%. With LEADTOOLS, vector images can also be converted and saved as any of the over 60 raster file formats supported by LEADTOOLS.

To work with vectors and vector handles, you can:

  • Rotate, translate and scale the entire image or selected object(s).

  • Use LEADTOOLS 3D viewing options including lighting, shadow, camera, polygon modes (points, wire-frame, filled).

  • Convert to and from WMF and EMF.

  • Render a vector image to a bitmap handle.

These features are included with:

LEADTOOLS Vector Imaging Pro


Additional Document Imaging Features

Available in LEADTOOLS Document and Medical Imaging toolkits.

Additional Document Imaging Features

The LEADTOOLS Document Imaging toolkit provides extended support for Image Display, Scanning / Screen Capture, and Image Processing features that are not supported in the LEADTOOLS Imaging Pro product, such as comprehensive annotations, specialized bitonal image display and processing, image clean-up, file formats optimized for document archival systems including MRC and ABC, high-speed scanning, OCR/MICR/ICR/OMR (character, hand-print and form processing) add-ons, WCF Services, Windows Workflow, CD/DVD Burning, and much more. It includes everything you need to create high performance applications specifically for the document imaging vertical market.

With calls for "paperless offices," "document archiving," and "electronic file cabinets," your clients are asking for more sophisticated and specific document imaging functionality to be included in your applications. LEADTOOLS' Document Imaging product line builds from LEADTOOLS' Raster Imaging technology to add features specifically for black and white imaging with the best possible performance.

This additional support includes:

  • 12 and 16 bit grayscale image support.

  • 8-16 bit grayscale lossy and lossless JPEG compression.

  • TWAIN scanning (16-bit grayscale and up to 48-bit color).

  • Fast Twain scanning capabilities.

  • Bitonal image processing, including document cleanup features like image deskew and despeckle.

  • Automated deskewing of bank check images.

  • Scale to Gray 1-bit image display.

  • AutoZone images into text and image regions.

  • Favor black display which preserves black objects when displaying zoomed-out 1-bit images.

  • Fast Rotate which rotates a bitmap in 90-degree increments.

  • Super compressed 1-bit or 24-bit bitmaps which can be kept compressed in memory.

  • WCF Services.

  • Windows Workflow.

  • CD/DVD Burning.

  • ABC write support.

  • MRC file format / compression.

  • ABIC file format / compression.

  • JBIG and JBIG2 file format / compression.

  • JPEG 2000 file format / compression.

  • LEAD CMW file format / compression.

For more information, refer to:

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

Annotations

LEADTOOLS Advanced Bitonal Compression (ABC)

LEADTOOLS Document Imaging Features

Document Clean-up

WCF Services

Windows Workflow

CD/DVD Burning

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

The following LEADTOOLS products can be added to this product:

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Virtual Printer Module

LEADTOOLS Barcode Modules

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


Document Clean-up

Available in LEADTOOLS Document and Medical Imaging toolkits.

Document Clean-up

Scanned documents often contain a number of undesirable elements, including dots, blobs, lines, borders, hole punches, inverted text, bumps and nicks. LEADTOOLS provides a number of properties, methods and events that will remove these imperfections and improve the appearance of scanned documents. LEADTOOLS Document Clean-up functions can also improve the results of OCR, ICR, and Forms Recognition/Processing.

Each function or method takes a number of parameters that control the performance of the corresponding removal process. Included in the parameters is a set of flags that allows you to obtain a LEAD region or a Windows region that contains all the elements removed from a document. For each element found by one of the removal methods, a corresponding event is triggered. These events provide a means of customizing the removal process, as well as creating your composite of the removed regions.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Annotations

Available in LEADTOOLS Document and Medical Imaging toolkits.

Annotations

LEADTOOLS offers a variety of annotation (document markup) options that can be added to document, grayscale and color images. LEADTOOLS allows the end-user to reposition nodes of an existing free-hand object, which prevents the user from redrawing the object. Enhanced redact objects allow you to restore parts of an image that were blacked out. When combined with annotation security, these redact objects provide a means of granting user-level access to parts of an image. Annotation objects can be stored as a separate object layer, or can be burned or embedded into the actual image. LEADTOOLS allows you to read or write annotations as an external file or as a Wang annotation tag within a TIFF file. With LEADTOOLS, you can choose between low level access to the annotations, or you can implement annotation support through a fully automated mode with a ready to use floating, customizable toolbar and pop-up menus. The superior annotation features provided in LEADTOOLS can be used in any application where image markup is required.

With LEADTOOLS Document/Medical Annotation support you can:

  • Create any of the following objects: line, arrow, rectangle, ellipse, polygon, freehand line, text, highlighter, hot spot, note, stamp, redaction, button, audio clip, video, freehand hot spots, points, protractors, cross-products, push pins, and rubber stamps.

  • Implement automated annotation support.

  • Implement DICOM Annotations (requires Medical SDK)

  • Implement annotation passwords (case-sensitive) providing security for every object.

  • Implement hyperlinks for every object. Hyperlinks can be user defined messages, programs to run, or jumps to Web pages.

  • Modify text strings used in automated annotation support.

  • Scale and position a group to fit the displayed bitmap.

  • Group and ungroup objects.

  • Apply an object or group to a bitmap.

  • Size and position an object or group.

  • Rotate an object or group.

  • Flip, reverse, or shear an object or group.

  • Save an object or group on the Windows clipboard.

  • Print an object or group.

  • Save an object or group in a file.

  • Save annotations as an external LEAD file, WMF file, or as a WANG compatible tag inside a TIFF file.

  • Save an object or group as a file in memory. (This is useful for database support.)

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


JBIG and JBIG2

Available in LEADTOOLS Document and Medical Imaging toolkits.

JBIG and JBIG2

JBIG is an acronym for 'Joint Bi-level Image experts Group'. This was a group of experts nominated by national standards bodies and major companies to work to produce standards for bi-level image coding.

The JBIG group has developed IS 11544 (ITU-T T.82) standard for the lossless compression of a bi-level image. It can also be used for coding grayscale and color images with limited numbers of bits per pixel. It can be used in a similar fashion as Group 3 or Group 4 fax, offering between 20% and 80% improvement in compression over these methods. JBIG compression averages about a 20:1 over the original uncompressed image.

LEADTOOLS completely supports all three types of images (bitonal, grayscale and color), giving you the ability to make full use of this powerful compression technology. LEADTOOLS also supports the progressive capability of JBIG, allowing you to store and send multiple representations of images at different resolutions without any extra storage overhead.

To achieve the highest compression ratios available in the JBIG format, LEADTOOLS takes full advantage of all the functional blocks of this robust standard:

  • The Adaptive Arithmetic Encoder, which presents the heart of this format, has the ability to predict and hence encode future data symbols based on the data which is being currently encoded.

  • The Adaptive Template Block provides real coding gain for images rendered by grayscale with halftoning. This gain ratio approaches 80% in some situations.

  • The Typical Prediction Block speeds implementations and provides some coding gain.

  • The Resolution Reduction Block is used to get a lower resolution version of an image so that no loss of data is encountered. This is mainly important for bi-level images, to avoid any deletion of thin lines.

  • The Deterministic Prediction Block provides good coding gain when saving more than one resolution layer in the same file.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS JPIP Module

Available as an Add-on for LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

JPIP (JPEG 2000 Interactive Protocol)

The JPIP (JPEG 2000 Interactive Protocol) features support interactive streaming of large images and associated image data using the minimum possible bandwidth. It is especially well-suited to using internet connections for viewing and manipulating large medical, geospatial, and very-high-resolution camera images stored on remote servers. It is an implementation of the JPEG2000, part 9 standard (ISO/IEC 15444-9), including both meta-data and code-stream elements.

JPIP client/server architecture allows storage of very large, compressed JPEG2000 images at the server, plus transmission of image resolution, quality and region of interest (ROI) as specified by a client. This allows client applications to interact with a stored image without transmitting the entire image, or decoding the entire image code-stream. The server and client components include a number of options for controlling this image streaming and decoding.

The JPIP features contain high level components that developers can easily plug into enterprise client/server applications, allowing them to immediately start streaming high-resolution images under low HTTP bandwidth connections.

Key Features:

  • Optimizes network efficiency through progressive image transmission, without sending redundant data.

  • Fast image viewing through progressive decoding of images resolutions, tiles, and components.

  • Suitable for browsing lossless high-resolution medical and geospatial images.

  • Supports JPEG2000 code-streams and multiple file formats (J2K, JP2 and JPX).

  • Supports streaming over HTTP V1.1 transport protocol

Server Component:

  • Gives fine control over allocated server bandwidth, total server bandwidth, client connections bandwidth, and chunk size.

  • Enables conservation of server resources through setting the maximum number of client connections, client lifetime, and timeouts.

  • Enables performance enhancement through splitting the streaming process among multiple servers running on different machines.

  • Supports interactive client requests and server response handling

Client Component:

  • Decodes low image resolutions and progressively decodes higher resolutions on user request.

  • Decodes user-requested regions of interest (ROI), component, and quality.

  • Enables local caching of images information for faster future viewing.

  • Controls the amount of data delivered in each request.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Virtual Printer

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Virtual Printer ($1495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

.NET classes

Product Description:

LEADTOOLS Virtual Printer is a virtual printer driver which provides a bridge between your application, and any other windows application that can create a print job. It allows you to capture the print job from any application as EMF and convert it to any supported LEADTOOLS format, both raster and document formats.

The included Document Writers can convert newly created EMF's, existing EMF's, or EMF's created from the Virtual Printer to any supported document format including PDF, WORD, HTML, TEXT, and many more!

Key Features:

  • Capture print jobs from any Windows application as EMF.

  • Programmatically install and un-install virtual printers to a target system.

  • Control access to the printer by locking it for use only by your application.

  • Configure the virtual printer to start your application when a print job is received.

  • Convert EMF files to any support raster or document format.

The LEADTOOLS installation program installs a sample LEADTOOLS Virtual Printer for you. When you print to this printer from any Windows application, the example program will execute and you can then save the print job as a document file or raster image file.

LEADTOOLS Virtual Printer Module is included in the following products:

LEADTOOLS Document Suite

LEADTOOLS Medical Imaging Suite

LEADTOOLS Virtual Printer Module may be added to the following products:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging


LEADTOOLS WCF Services

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS WCF Services

LEADTOOLS WCF includes services for file loading and saving, image processing, document image processing and clean-up, OCR and barcode detection, reading and writing. These new services will be invaluable to developers creating enterprise level client/server applications.

Built on top of the .NET Framework, the Windows Communication Foundation (WCF) was designed to unify Web Service technologies into a single service-oriented architecture (SOA). Web Services are APIs that are hosted on a remote computer (although, with WCF it can actually be hosted locally as well!). Services are hosted remotely and are accessed by adding a Web Reference (or Service Reference) to the URL of the service, (instead of adding a reference to a local .NET DLL to your project). Web Services are usually stateless, meaning that the service is called, does something and then returns, and does not store or remember anything about the call. All the data necessary for the process is passed in the call.

Using WCF, programmers develop services based on the contract requirements. Applications save and load data as transacted web services. Protocol requirements, etc. are determined when the application is deployed.

Key Features

  • Provides a unified framework for building service-oriented imaging applications utilizing transacted Web services.

  • Single programming model unifies the capabilities of ASMX, WSE, Remoting, COM+ and MSMQ.

  • Utilizes SOAP (Simple Object Access Protocol) for communication between processes, allowing interoperability between LEADTOOLS WCF applications and any other process that communicates via SOAP messages.

  • Saves and loads data to disks, databases, HTTP, HTTPS and FTP servers.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Silverlight

Available in LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Silverlight

The LEADTOOLS Silverlight toolkit contains an image viewer control that supports loading and displaying over 100 LEADTOOLS supported formats. To make the navigation of large or zoomed images easier, the viewer includes a pan window, several user-interactive modes (scale, center at, and zoom to), a customizable magnifying glass, and several size mode viewing options (normal, fit, fit width, and stretch). The provided viewer allows developers to work with both the native Silverlight image type (System.Windows.Media.Imaging.BitmapImage), as well as the LEADTOOLS native RasterImage object.

To further extend the viewer, LEADTOOLS Silverlight toolkit also includes a full featured annotation library. This allows users to mark-up images with several different annotations including rectangle, ellipse, hilite, redact, text, ruler, and more. Comprehensive DICOM support is also included adding support for DICOM datasets (create, load, view, edit, and save), window level, and more.

LEADTOOLS Silverlight also includes over 130 different image processing filters and transforms. Some of these include rotate, resize, crop, 3D effects, sharpen, grayscale, document cleanup, various pixel shaders, and many more.

When used in conjunction with LEADTOOLS WCF services, LEADTOOLS Silverlight can load over 150 different file formats. LEADTOOLS WCF Services also add support for enhanced document imaging features such as barcode read/write, and OCR.

LEADTOOLS Silverlight includes:

  • Full featured annotation library including support for Rectangle, Ellipse, Hilite, Line, Redact, Text, Ruler, Protractor, CrossProduct, Image, TextPointer, Point, Curve, Point, Polygon, and Polyline objects.

  • Complete DICOM Dataset support including the ability to create, load, view, edit, and save DICOM datasets.

  • A separate Pan Window Control for navigating larger images in the main control. Each Pan Window can be attached to any viewer control. Since the Pan Window is its own control, it can be positioned and treated just like any other Silverlight3 Control in XAML.

  • Several interactive modes which can be applied to the viewer including pan, scale, center at, and zoom to.

  • Several size modes which can be applied to the viewer (with the ability to scroll) including Normal, Fit, FitAlways, FitWidth, and Stretch.

  • A customizable magnifying glass which can be applied to the viewer. Configurable options include scale, shape, size, crosshair, and more.

  • Over 130 image processing filters, transforms, and pixel shader effects.

  • Ability to integrate with LEADTOOLS WCF Services allowing support for 150+ formats, barcode read/write, and OCR.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Windows Workflow

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Windows Workflow

The LEADTOOLS Windows Workflow offering includes WF activities for file loading and saving, TWAIN and WIA scanning, image processing, document image processing and clean-up, reading and writing barcodes, and Optical Character Recognition (OCR). These new activities can be used in any application framework that supports Windows WF such as SharePoint and Microsoft CRM.

Windows Workflow Foundation (WF) is a development framework that enables you to embed workflows in .NET Framework applications. A workflow application is a software application which coordinates and manages individual units of work, encapsulated as activities. Activities can be chained together to automate one or more processes. The processes are usually business-related, but can be any process that requires a series of steps that can be automated via software.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Media Writer

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Media Writer

The LEADTOOLS Media Writer Module extends the LEADTOOLS toolkit by adding functionality for programmatically burning DVD images and ISO files. DVD images can be burned to: DVD –R, +R, –RW. +RW and +DL; as well as CR –R, and -RW formats.

Key features:

  • Burn DVD/ISO images

  • Enumerate drives

  • Detect drive types

  • Detect supported media for each drive

  • Load / Eject drives

  • Get supported speeds for each drive

  • Select burn speed

  • Detect progress of burn operations

LEADTOOLS includes a DVD burner demo.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


Additional Medical Imaging Features

Available in LEADTOOLS Medical Imaging toolkits.

Additional Medical Imaging Features

LEADTOOLS Medical Imaging SDK's provide extended support for Image Display and Image Processing features that are not found in the LEADTOOLS Imaging Pro and Document Imaging toolkits. This additional support includes:

  • Hardware Support: Support for the largest set of hardware manufacturers in the industry.

  • High-Level Tools:

    • Cookie cutter tool: Extract individual slices from a radiographic scanned film (useful for identifying each slice inside a scanned MRI or CT series).

    • MRI Brain Analysis Tool: Used to calculate the ratio between the corpus callosum (white matter in the middle of the brain) and the brain sphere.

    • Medical Image Viewer Control: a medical image display container for building medical display applications such as DICOM viewers, view stations, teleradiology solutions, and high-end diagnostic workstations found in radiology and other medical specialty departments. Dramatically reduces development time.

  • DICOM-specific annotations such as point, polyline, anchor text and curve.

  • Extended TWAIN scanning (16-bit grayscale and up to 48-bit color).

  • Over 100 medical image processing functions that support extended grayscale data (12-16 bit signed and unsigned), optimized to meet the specific demands of the medical imaging market. Highlights include:

    • Converting signed images to unsigned images.

    • True 16 bit LUT support.

    • Paint callbacks which can be used for custom painting to grayscale video cards.

    • Converting unsigned images to signed images.

    • Embedded Image Overlays.

    • Statistical information for a region or bitmap.

    • Auto-detection of the minimum and maximum intensity, and low and high bits used in the image data.

    • Painting 10–16-bit images using Bilinear or Bi-cubic resizing on-the-fly.

    • On-the-fly re-mapping of 10–16-bit grayscale images to Windows display devices, using a LUT with pseudo-color support.

    • 12- and 16-bit grayscale image processing and display with LUT and window leveling.

    • Remap 12–16-bit grayscale image data using a user-defined lookup table.

    • Conversion of 12- to 16- bit grayscale images to 8- or 24-bit.

    • Shift bit range in extended grayscale data.

    • 16-bit Grayscale histograms.

  • Specialized and Extended Grayscale file format support:

    • Creating or loading 12- and 16-bit grayscale and 48- and 64-bit color images from raw data from disk, memory, or file offset.

    • 8–16 bit grayscale lossy and lossless JPEG and JPEG2000 compression, including signed image data.

    • Importing/exporting TIFF files to/from 10-,12-, 16-, and 32-bit grayscale, and 48- and 64-bit color .

    • Import/export TIFF with JPEG2000 lossy or lossless compression of 12–16-bit grayscale signed and unsigned images.

    • Importing/exporting to/from JFIF (JPEG) and JTIF (TIFF with JPEG) files compressed using 12-bit grayscale lossy or 12- and 16-bit lossless compression.

    • 16-bit image data in Intel or Motorola formats.

For more information, refer to:

LEADTOOLS PACS Imaging

DICOM Basic Feature

DICOM Annotation Features

DICOM Communication Features

DICOM Security Features

These features are included with:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

The following LEADTOOLS products can be added to this product:

LEADTOOLS Medical Multimedia Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Virtual Printer Module

LEADTOOLS Barcode Modules

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


Medical Image Viewer Control

Available in LEADTOOLS Medical Imaging toolkits.

Medical Image Viewer Control

The LEADTOOLS Medical Image Viewer Control is a high-level component for building medical display applications such as DICOM viewers, view stations, teleradiology solutions, and high-end diagnostic workstations found in radiology and other medical specialty departments. Whether you are building a PACS for radiology, cardiology, mammography, ophthalmology, pathology, dermatology, dentistry, or any other specialty, this control will eliminate the complexity from your project and give you a solid foundation you can rely on.

Key Features:

  • Display medical grayscale and colored images including MRI, CT, Digital X-Ray, and Ultrasound.

  • Display overlay information on the images—an essential feature for any high-end medical viewer. The programmer has full control over the text to be displayed and how it should be positioned and sized inside each window. The control also comes with a set of built-in overlays such as: window center, window width values, and field of view.

  • Adjust screen layout both manually and programmatically. For example, display an MRI image enlarged 2X2, beside an unenlarged (1x1) XA series of four images at 1X1.

  • Load and play animations.

  • Interpolated image display for higher quality.

  • Built-in ruler that adjusts based on the DPI of the image and the zoom or scale factor.

  • Full control over display container properties such as colors, cursors, and rulers.

  • Reset Window Level, Position, Rotation, Zoom

  • Viewer Display Cell Support Includes:

    • Add, remove, or refresh pages or images to the viewer cells.

    • Add different images with different sizes to the same cell.

    • Fit images to a cell.

    • Manage different types of medical viewer overlay tags like Frame, Scale or Ruler unit.

    • Change the scale and offset of a single sub-cell. Includes an event that fires when the active sub-cell has been changed.

    • Calibrate cells without using the annotation ruler.

    • Freeze, and unfreeze cells.

    • Invert the images in a specified cell or sub-cell.

    • Get or set the perspective rotation angle of the specified cell or sub-cell

  • Built-in tools include:

    • Window Leveling: Maps grayscale intensities using a user defined color map (LUT). Includes set/reset default values, with low memory options.

    • Zooming and scaling. Get or set image information like height, width, or coordinates.

    • Panning and moving.

    • Image magnification.

    • Single-click stacking or scrolling from one image to another in a series.

  • Annotation Support Includes:

    • Event notification when a new annotation object is created.

    • Event notification when an annotation is selected.

    • Load and save annotation objects drawn on the control.

    • Rotate, flip and reverse the annotation container.

    • Change fore and back color of the text object.

  • Region of Interest Support Includes:

    • Load, save, and print region information drawn on the control.

    • Event notification when a region is created, removed or changed.

    • Click-and-drag mouse actions to expand, shrink, nudge, and change size or shape of region borders.

  • Tool Settings and Actions Include:

    • Apply tool effect programmatically or through user interaction.

    • Apply tool effect to a single image, to all images in a series, or to all series managed by the control.

    • Apply actions and adjust the MedicalViewer while an animation is running.

    • Obtain image coordinates corresponding to user-specified mouse coordinates.

    • Events for mouse actions.

    • Specify mouse button actions.

    • Specify keyboard button actions.

    • Specify cursor display and style for annotations and regions.

Typical applications that can be built using this control

  • High-end medical diagnostic workstations.

  • Medical review and quality assurance stations.

  • DICOM viewers.

  • Light-weight viewers that are typically distributed on a CD with patient images.

  • Web-based medical viewers.

These features are included with:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Web Viewer Framework

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Web Viewer Framework

LEADTOOLS Web Viewer Framework enables programmers to quickly build high-quality, full-featured, web-based medical image viewer applications.

It includes WCF components and services that enable you to implement high-level interfaces for distributing medical studies from a server to web clients, even with very limited knowledge of web hosting and web service development. This is ideal for web-based solutions like querying patient studies and viewing images from remote computers using Microsoft Internet Explorer.

The plug-in capable design also allows developers to use the framework for non-DICOM images or binary data transfer, and to extend an implemented web service to include application-specific data transfer and communication capabilities.

Key Features:

  • Rich Client Web Viewer. This feature-rich, powerful WinForm control includes:

  • Tools most commonly used in radiology applications, like window level, rotate, flip, and invert

  • Synchronized scrolling, zooming and panning.

  • Image markup and annotation.

  • Measurement and region processing tools.

  • Options for low-memory usage in large-study viewing.

  • Signed and unsigned display for extended grayscale images typical of medical applications.

  • Multiple display layouts, including stack, cine and series view.

  • Printing to Windows printers.

  • WCF Services. Web-hosted services provide/enable you to:

  • Addresses and Interfaces to manage, store, query and Retrieve DICOM data sets, image sets or thumbnails.

  • Upload single DICOM file or a set from DICOM media using DICOM DIR.

  • Query for patient, study and series.

  • Get DICOM tags only.

  • Get full DICOM files with all image information.

  • Get full resolution image or a thumbnail representation.

  • Perform Multi-threaded background image streaming to enhance performance.

  • Support Thin Client and Rich Client implementations.

  • Dynamically remove or add plug-in services as needed.

  • WCF Security and Client-Side Cache Management.

  • Certificate exchange for strong message encryption and client authentication.

  • Limit service access to authorized users.

  • Options to manage user authentication, groups, and roles.

  • Client-side Cache Management

  • Client-side caching of download studies for fast reloads and network traffic reduction.

  • Local cache storage management

  • Encryption option for local cache to protect patient's health record..

  • CAB File Generator. This wizard generates the .Net runtime rights .CAB file

These features are included with :

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Medical Workstation Viewer Demo

Available in LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical Workstation Viewer

The Medical Workstation Viewer is an end-user-like application with functionality comparable to many DICOM viewers used today in the health care industry. It can be used without modification by medical professionals, by device manufacturers (as a Modality Workstation viewer), research facilities, or anyone that has a need for viewing DICOM images. The source code is provided for easy customization and branding. The workstation is built on LEADTOOLS PACS Framework components, and supports:

  • DICOM SCU Query/Retrieve, Store, Storage Commit

  • DICOM SCP service to provide Query/Retrieve and Store

  • DICOM Media import

  • Medical Image Viewing (display layouts, annotations, Zoom, Pan, Window-Level tools, etc)

  • User Access Control

  • 3D volume generation and viewing for DICOM Series

These features are included with :

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


LEADTOOLS Medical Multimedia Filter Pack

Available as an Add-on to LEADTOOLS Medical Imaging toolkits.

LEADTOOLS Medical Multimedia Module

All you need to compress and decompress DICOM Videos

The Medical Multimedia Module includes LEADTOOLS Multimedia SDK plus a suite of state-of-the-art DirectShow filters for compressing and decompressing video and audio data inside DICOM files. This feature-rich product was designed to eliminate the complexity from converting cine images and video streams to DICOM objects including X-ray Angiography (XA), Ultrasound (US), Visible Light (VL), Secondary Capture (SC) and much more. This Filter Pack utilizes the most advanced compression algorithms used in the industry and approved by the DICOM standard including MPEG-2, Motion JPEG, and JPEG2000.

The Medical Multimedia Module includes three main components: the Multimedia SDK, the Writer and the Reader.

Multimedia SDK

Writer (encode video sequences in DICOM)

The writer component includes the DirectShow filters that are used for creating DICOM objects with compressed video and audio data.

Key Features:

  • Ability to create DICOM files with both video and audio using MPEG-2 compression. The user can adjust the different attributes of the MPEG-2 stream including bit rate and quality factor.

  • Ability to create DICOM files with video data (cine images) using lossy and lossless JPEG and JPEG2000 compression with the option to adjust quality factor.

  • Add video data to either an existing DICOM file or create a new one from a set of predefined DICOM classes or IODs.

  • Accepts 8-bit RGB, 24-bit RGB, 16-bit UYVY or 16-bit YUY2 data.

  • Includes a number of video processing filters including:

  • Auto Contrast

  • Auto Intensity

  • Auto Level

  • Video Text Overlay

  • Video Crop

  • Can be used with an existing application that uses DirectShow, or programmatically from the LEADTOOLS Medical Imaging toolkit.

Examples of DICOM objects that can be created using the Writer component:

  • Secondary Capture Multi-Frame True Color Image Storage.

  • Video Endoscopic Image Storage.

  • Video Photographic Image Storage.

  • Video Microscopic Image Storage.

  • Ultrasound Multi-frame Image Storage.

  • X-Ray Radiofluoroscopic Image.

  • X-Ray Angiographic Image Storage.

  • Secondary Capture Multi-frame Grayscale Byte Image Storage.

  • Secondary Capture Multi-frame Grayscale Word Image Storage.

MPEG-2 Encoding in DICOM:

  • MPEG-2 is a high quality video compression and is primarily targeted for applications that require higher bitrates or high bandwidth usage. The DICOM standard uses MPEG-2 lossy compression with middle range quality, which typically delivers between 30 Mbytes and 60 Mbytes per minute of video.

  • The DICOM MPEG-2 objects created using the writer fully adhere to the rules of MPEG-2 encoding in DICOM which are described by the new transfer syntax “MPEG-2 Main Profile @ Main Level” (1.2.840.10008.1.2.4.100).

  • Some of the typical modalities that can take advantage of MPEG-2 encoding in DICOM include Endoscopy, Cardiology and Micro-surgery.

DirectShow filters included as part of the Writer component:

  • LEAD DICOM Write Filter.

  • LEAD MPEG-2 Standard Video Encoder.

  • LEAD MPEG-2 Multiplexer.

  • LEAD MCMP-MJPEG Video Codec.

  • LEAD Auto Contrast Filter.

  • LEAD Auto Intensity Filter.

  • LEAD Auto Level Filter.

  • LEAD RGB Converter.

  • LEAD Video Text Overlay Filter.

  • LEAD Video Crop Filter.

Reader (play DICOM videos in any media player)

The reader component includes a set of DirectShow filters that register into the Windows collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize these filters to play video (cine) data in a DICOM file.

Key Features:

  • Can be used with an existing application that supports DirectShow, or programmatically from the LEADTOOLS Medical Imaging toolkit.

  • Ability to play or Cine any DICOM file with any type of compression including MPEG-2, lossy and lossless JPEG and JPEG2000.

  • Fast and optimized video decompression.

  • Playback options include control of the stream speed by changing the frame playback rate. In addition to the basic stream and speed control functionality, LEADTOOLS developers can "preview" a LEAD DICOM dataset in memory before saving to disk.

  • DICOM Cine Playback - DICOM Cine Loop:

  • A cine loop is the continuous display of a set of images or frames that convey the effect of motion and is considered a very useful diagnostic tool. With the help of the reader the user can treat DICOM cine as a regular video file:

  • Play: start or resume DICOM cine play.

  • Pause: pause DICOM cine play.

  • Stop: stop play mode and go to the beginning of the video clip.

  • Previous Frame: display the previous frame in the cine loop.

  • Next Frame: display the next frame in the cine loop.

DirectShow filters included as part of the reader:

  • LEAD DICOM Read Filter

  • LEAD MPEG-2 Video Decoder

  • LEAD MPEG Audio Converter

For more details on this feature, refer to:

http://www.leadtools.com/SDK/Medical/medical-MMfilterPack.htm.

These features are included with:

LEADTOOLS Medical Imaging Suite

This product may be added to:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables Redistributables | Documentation | Support | Licensing


DICOM Basic Features

Available in LEADTOOLS Medical Imaging toolkits.

DICOM Basic Features

In medical environments, DICOM Standards facilitate interoperability of medical imaging systems, related images, and related information. They define protocols for exchanging digital information between medical imaging equipment (such as CT and MR scanners) and other systems, with strong emphasis on diagnostic medical imaging as practiced in radiology, cardiology and related disciplines.

LEADTOOLS is committed to full and complete support for these industry-standard medical imaging protocols, giving programmers access to medical images retrieved from the widest possible variety of digital imaging modalities. LEAD’s Medical Imaging toolkits include the richest DICOM support in the industry. These DICOM features include:

  • COMPLETE support for the DICOM 3 (2008) base standard, including:

    • Automatic DICOM file recognition, including Little-Endian/Big-Endian, Implicit/Explicit VR, and others.

    • All standard IOD classes and modalities such as CR, CT, MR, NM, US, RF, SC, and VL.

    • All standard data element tags.

    • All standard Value Representations (VRs), including Other Float String.

    • All IODs (classes) in the latest DICOM specification 2008 and Final Text Supplements additional to 2008 Base Standard

    • Full support for Final Text DICOM Supplement 137 - MPEG2 MP@HL Transfer Syntax

  • Simplified data handling:

    • High-level and low-level functions for easy navigation and manipulation (insert, delete, modify) of Data Sets.

    • Context Groups support. The use of Coded Concepts in DICOM facilitates unambiguous communication of concepts or terms. LEADTOOLS supports all the context groups defined by the DICOM Content Mapping Resource (DCMR) specified by PS 3.16 of the DICOM Standard.

    • Automatic addition of Item Delimitation Item (FFFE, E00D), and Sequence Delimitation Item (FFFE, E0DD) (VR of "SQ").

    • Easy-to-manipulate ordinal positioning of Items (FFFE,E000).

    • Handling of repeating groups with multiple overlays and curve data.

    • Interface for private IODs.

    • Interface for Private tags.

  • Robust image handling and processing:

    • Support for 1, 8, 10, 12, 16, 32-bit grayscale and 24-bit color images including:

    • JPEG (8, 10, 12, 16-bit Lossless grayscale, 8, 12 bit lossy grayscale, 24-bit lossless and lossy color)

    • JPEG2000 (including lossy and lossless 8-16 bit grayscale images and 24-bit color)

    • Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full, YBR_RCT, and YBR_ICT).

    • Run Length

    • Uncompressed (1, 8, 10, 12, 16, 32 grayscale and 24 bit color)

    • Single or multi-frame images (compressed or uncompressed).

    • True 16 but LUT support.

    • Support for rendering images directly to grayscale video cards.

    • Encapsulated or Native encoding of pixel data for single or multi-frame compressed or uncompressed images.

  • DICOM Annotation Object support. Store/retrieve DICOM annotations from a dataset and convert them to LEAD Annotation objects (and vice versa). Annotations can also be converted to regions of interest for additional statistical calculations and for storing to DICOM Presentation State.

  • Easy implementation and high-level support for:

    • DICOM Encapsulated CDA (Clinical Document Architecture)

    • Raw Data encapsulation and retrieval

    • DICOM Encapsulated PDF

    • DICOM Waveforms, including electrocardiography (ECG), hemodynamic curve data, cardiac electrophysiology, and audio signals (WAV files).

    • DICOM Basic Directory. Create DICOMDIR in few lines of code.

    • Overlay Planes (including support for embedded overlay bit in pixel data).

    • Annotation and Graphics objects.

    • Shared Functional Groups and Per-Frame Functional Groups.

    • Change between transfer syntaxes with one function call.

    • DICOM Digital Signature Profile support to ensure that data has not been tampered with. Includes support for Base RSA, Creator RSA, and Authorization RSA digital signature profiles.

    • Window Leveling. Window leveling is a linear conversion from stored pixel values to values to be displayed. LEADTOOLS can map the stored pixel values of interest, using a user defined color map (using a LUT or Palette) or linear gray LUT.

    • DICOM LUT/Overlay/Palette support. The high-level support for Modality LUT, VOI LUT, Palette Color Image in LEADTOOLS Medical Imaging means developers can implement DICOM Presentation states into an application with ease. LEADTOOLS can also apply the Modality LUT to the image data to further simplify image processing and statistical calculations.

    • Cut-and-paste source code and ready-to-use executables.

    • Multiple programming interfaces: C DLL, C++ Class Library, .NET Class Libraries, and COM Interoperability for DICOM basic features.

These features are included with:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

The following LEADTOOLS products can be added to this product :

LEAD MPEG-2 Video Codecs

LEADTOOLS Medical Multimedia Module

L EADTOOLS Medical Multimedia Module Features

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS Virtual Printer Module

LEADTOOLS Barcode Modules

LEADTOOLS OCR Modules

LEADTOOLS ICR Modules

LEADTOOLS OMR Module

LEADTOOLS PDF OCR Plug-in


DICOM Annotation Features

Available in LEADTOOLS Medical Imaging toolkits.

DICOM Annotation Features

The LEADTOOLS DICOM Annotation features provide support for saving LEADTOOLS annotations directly to and from a DICOM Data Set, as private data. This support allows you to save multiple annotations to the same file, with password protection, and edit the annotations later. You can also convert to/from DICOM and LEAD Annotation objects.

LEADTOOLS offers a number of functions to manipulate DICOM graphic and text annotations and their related attributes, defined under the "Grayscale Softcopy Presentation State" Information Object Definition (IOD) in the DICOM standard. This IOD outlines attributes of vector graphics and text annotations that should be made available by a display device for application to an image.

Using LEADTOOLS DICOM Annotations, information about the Graphic Annotation Module can be retrieved from any Presentation State object and applied to a bitmap image as graphic layers. Developers can also easily add other graphic objects defined in the DICOM Standard to different layers in a presentation state object.

Further, high level interfaces are provided to convert DICOM annotations into LEADTOOLS annotations, and vise versa. The toolkit provides you with the ability to store and retrieve LEADTOOLS annotation files as private data elements inside a DICOM dataset. It supports storing up to 256 single page or multi-page annotation files, either in the LEAD native format or a binary encoded format.

These features are included with:

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite


DICOM Communication Features

Available as an Add-on to LEADTOOLS Medical Imaging toolkits.

DICOM Communication Features

The LEADTOOLS DICOM Communication features provide support for the following:

  • TCP/IP support for the communication of medical data using the DICOM 3.0 protocol.

  • High Level PACS Framework for simplifying the creation of DICOM client/server applications. The framework takes care of the entire behind the scenes work leaving the developer to only develop the service class plug-in implementations (Store, Find, Query/Retrieve, Modality Work List and Storage Commit, etc).

  • High-level functions for initiating and terminating Associations (connections between DICOM applications).

  • Automatic processing for filling out PDU structures (Protocol Data Units).

  • Automatic and transparent conversion of DICOM Data Sets to/from the specific Transfer Syntax required by the associated Application Entities (the connected DICOM client(s) and server(s)).

  • Full Support for all Service Classes - Easy to implement all possible DICOM Service Classes as client (SCU) and/or server (SCP)

  • DICOM Verification Service Class

  • DICOM Storage Service Class

  • DICOM Query/Retrieve Service Class

  • DICOM Study Content Notification Service Class

  • DICOM Patient Management Service Class

  • DICOM Study Management Service Class

  • DICOM Results Management Service Class

  • DICOM Print Management Service Class

  • DICOM Media Storage Service Class

  • DICOM Storage Commitment Service Class

  • DICOM Basic Worklist Management Service Class

  • DICOM Queue Management Service Class

  • Direct support for PACS

The Dicom Communication features also provide support for the following Command Sets, and their respective Command Elements.

  • C-STORE-REQUEST

  • C-STORE-RESPONSE

  • C-FIND-REQUEST

  • C-FIND-RESPONSE

  • C-GET-REQUEST

  • C-GET-RESPONSE

  • C-MOVE-REQUEST

  • C-MOVE-RESPONSE

  • C-CANCEL-REQUEST

  • C-ECHO-REQUEST

  • C-ECHO-RESPONSE

  • N-EVENT-REPORT-REQUEST

  • N-EVENT-REPORT-RESPONSE

  • N-GET-REQUEST

  • N-GET-RESPONSE

  • N-SET-REQUEST

  • N-SET-RESPONSE

  • N-ACTION-REQUEST

  • N-ACTION-RESPONSE

  • N-CREATE-REQUEST

  • N-CREATE-RESPONSE

  • N-DELETE-REQUEST

  • N-DELETE-RESPONSE

These features are included with:

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables Redistributables | Documentation | Support | Licensing


DICOM Security Features

Available as an Add-on to LEADTOOLS Medical Imaging toolkits.

DICOM Security Features

LEADTOOLS Dicom Security features support the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. This support includes the Basic TLS Secure Transport Connection Profile and ISCL Secure Transport Connection Profile to help integrators create DICOM applications with communication to be HIPPA compliant.

The LEADTOOLS DICOM Security features include:

  • Computer or Entity Authentication

  • Confidentiality

  • Data Integrity.

  • TLS using the Secure Hash Algorithm message authentication

  • Authentication based on RSA certificates

  • DES and triple DES (3DES) encryption mode

  • "Three-pass-four-way" mutual authentication protocol support

  • Ciphersuite negotiation.

  • DES-CBC encryption (ISCL standard DES encryption in cipher block chaining mode)

  • No encryption (ISCL standard)

  • DESMAC (64 bit) and MD5 (128 bit) message authentication codes (ISCL)

  • Support for the INTERNAL AUTHENTICATE command

  • Support for the EXTERNAL AUTHENTICATE command

  • Support for the GETCHALLENGE command

  • The ability to send secured or unsecured messages, regardless of the encryption mode

These features are included with:

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables Redistributables | Documentation | Support | Licensing


Files To Be Included With Your Application

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Files To Be Included With Your Application

Files for redistribution are installed by the LEADTOOLS setup. For more information on the installation directory structure, refer to the Installation Directory topic in the help file for the relevant toolkit, module, or plug-in.

Note: | You may not copy or redistribute files without obtaining the proper license. In some cases, the license is included with your initial purchase of LEADTOOLS. In other cases, you must obtain a license from a third party or enter into a royalty agreement with LEAD to obtain the proper license. For these special licensing situations, see the notes below accompanying the specific file.
Note: | You may not distribute header files with your application, and you may not provide software development capabilities in your application.

Please note that LTKRN is required for applications, and LTWVC is required for all C++ Class Library applications. For more information on LTKRN and other files, refer to the Files To Be Included With Your Application topic in the help file for the relevant toolkit, module, or plug-in.

Note: | All Unicode versions of LEADTOOLS require Microsoft Unicode Layer for Windows (UNICOWS.DLL) in order to function on Windows 95/98/Me. You can obtain MSUL from: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnanchor/html/anch_mslu.asp.
Note: | For a listing of the exact DLLs and Libraries refer to for the API, .for the CLIB, or to for Multimedia.


Demo Programs

Available in LEADTOOLS Imaging Pro, Vector, Document, and Medical Imaging toolkits.

Demo Programs

Demo programs are in separate EXAMPLES subdirectories of the path where you installed your product (such as C:\LEAD Technologies\LEADTOOLS 1X\Examples\C DLL or \ClassLibrary\MSVC), where 1X indicates the version you installed.

The executable files for these examples were compiled with all LEADTOOLS capabilities unlocked. However, for redeployment, some of these capabilities require product-specific unlock keys. Otherwise, if you recompile the examples, the resulting executable files will not have the locked capabilities.

To unlock and redeploy these capabilities, you must purchase an appropriate product license, such as that included with a LEADTOOLS Document/Medical toolkit.

Note:

You can run the example programs on your system by clicking the appropriate buttons in online help. If you try to run an example program that is not on your system, an error message will appear.


LEADTOOLS DICOM PACS Module

Available as an Add-on to LEADTOOLS Medical Imaging toolkits.

LEADTOOLS DICOM PACS Module ($3495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL, C++ class library, and .NET classes

Product Description:

By adding the LEADTOOLS DICOM PACS Module to the LEADTOOLS Medical Imaging SDK, you get everything you need to create both client and server components of a picture archive and retrieval system (PACS) that can retrieve, distribute, and present medical images. The module includes full support for medical data communications, automated processing, and all DICOM client/server classes, command sets, and command elements.

Security features fully support secure transport connection profiles with authentication, whether encrypted or unencrypted.

This module supports all storage IOD classes and service classes defined in the DICOM version 3 2008 base standard.

This product includes:

DICOM Communication Features

DICOM Security Features

This product may be added to:

LEADTOOLS Medical Imaging

Demos | Sample Programs | Unlocking Features | Install Directory | Redistributables Redistributables | Documentation | Support | Licensing


LEADTOOLS OMR Plus

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OMR Plus Module ($995)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL and .NET classes

Product Description:

The LEADTOOLS OMR Plus module provides functions, properties, methods, and events for easily incorporating optical mark recognition into your OCR applications.

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OMR.htm

This product includes:

LEADTOOLS OMR Modules

This product may be added to:

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging


LEADTOOLS OMR Professional

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS OMR Professional Module ($1495)

Price includes:

Development seat and application license. Runtime licenses required for internal or commercial deployment. Stand alone, concurrent and server licenses available.

Platform Components:

C DLL and .NET classes

Product Description:

The LEADTOOLS OMR Professional module provides functions, properties, methods, and events for easily incorporating the fastest and most accurate optical mark recognition engine into your OCR applications.

For background and full details, see:

http://www.leadtools.com/SDK/Document/Document-Addon-OMR.htm

This product includes:

LEADTOOLS OMR Modules

This product may be added to:

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging


LEADTOOLS Silverlight 3

Available as an Add-on for LEADTOOLS Document and Medical Imaging toolkits.

LEADTOOLS Silverlight 3

The LEADTOOLS Silverlight 3 Image Viewer control supports the loading and display of all Silverlight 3 supported image formats and can be easily extended to display any image format supported by LEADTOOLS including JPEG 2000, JBIG, DICOM and PDF. The viewer features several user interactive modes including pan, scale, center at, zoom to and customizable mag glass. Additionally, images can be zoomed and displayed using several different size modes such as normal, fit, fit width and stretch. To make the navigation of large or zoomed images easier, the viewer includes a pan window.

Because the LEADTOOLS Silverlight 3 Image Viewer was designed with extensibility in mind, the viewer can be effortlessly extended with additional features. By leveraging LEADTOOLS WCF services, document image clean up, image processing and barcode creation are just some of the features that can be seamlessly incorporated into applications that use the LEADTOOLS Silverlight Image Viewer.

LEADTOOLS includes sample Silverlight 3 projects to demonstrate all of the viewer's capabilities and how to extend the viewer to display over 150 image formats supported by LEADTOOLS.

Key Features

  • Supports several interactive modes including pan, scale, zoom, and mag glass.

  • Supports several size modes including normal, fit, fit width, and stretch.

  • Easily extended to support over 150 formats using LEADTOOLS WCF Services.

These features are included with:

LEADTOOLS Document Imaging

LEADTOOLS Recognition

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS PACS Imaging

LEADTOOLS Medical Imaging Suite